summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:30:20 -0300
committerMarcos Heredia2015-06-09 11:30:20 -0300
commit1ae743be43efaa16b1021b09411758a34ad73b72 (patch)
treed7d73f53155c8401a74e4211add0a3da92d4b61c
downloadaur-1ae743be43efaa16b1021b09411758a34ad73b72.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--updatefont.install15
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36ed075e70ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-quattrocento
+ pkgdesc = Classic, Elegant, Sober and Strong typeface, from Pablo Impallari
+ pkgver = 2.000
+ pkgrel = 1
+ url = http://www.impallari.com/quattrocento/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-20-source.zip
+ md5sums = 1cfccff569ae135e2eadf50a7cb326a4
+
+pkgname = ttf-impallari-quattrocento
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abdbcda4b66d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="quattrocento"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=2.000
+pkgrel=1
+pkgdesc="Classic, Elegant, Sober and Strong typeface, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/${_font}/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+#source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+source=("http://www.impallari.com/media/uploads/prosources/update-20-source.zip")
+md5sums=('1cfccff569ae135e2eadf50a7cb326a4')
+
+package() {
+ cd ${srcdir}/*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}