summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:31:02 -0300
committerMarcos Heredia2015-06-09 11:31:02 -0300
commitac7e59df0b7b1fe1b5f8b0c99424f934df09feac (patch)
tree9dcf9d6d3db2c4651d3c09d75fc796d7ad7fa7ee
downloadaur-ac7e59df0b7b1fe1b5f8b0c99424f934df09feac.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install16
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3188e18fd3e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-raleway-dots
+ pkgdesc = A dotted version of Raleway, from Pablo Impallari
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.impallari.com/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-55-source.zip
+ md5sums = bd4538079ad667cf5f63f6d77cb2a503
+
+pkgname = ttf-impallari-raleway-dots
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9412d078eded
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="raleway-dots"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.0
+pkgrel=1
+pkgdesc="A dotted version of Raleway, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/uploads/prosources/update-55-source.zip")
+md5sums=('bd4538079ad667cf5f63f6d77cb2a503')
+
+package() {
+ cd ${srcdir}/R*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..7c7762f6887c
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}