summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:31:31 -0300
committerMarcos Heredia2015-06-09 11:31:31 -0300
commit9f327f006c3790a813f155f8eb00db5f4035e796 (patch)
treeb68546442daa6dfee5d6cb3fd76ce15cdcaf875d
downloadaur-9f327f006c3790a813f155f8eb00db5f4035e796.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8d26200f6dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-ranchers
+ pkgdesc = 'Relaxed interpretations' of sans serif typefaces typical of 1950, from Pablo Impallari
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.impallari.com/projects/overview/ranchers
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-69-source.zip
+ md5sums = cfcf1d48069d55010dd533ae0c7adaff
+
+pkgname = ttf-impallari-ranchers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec7792da494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="ranchers"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.0
+pkgrel=1
+pkgdesc="'Relaxed interpretations' of sans serif typefaces typical of 1950, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/projects/overview/ranchers"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/uploads/prosources/update-69-source.zip")
+md5sums=('cfcf1d48069d55010dd533ae0c7adaff')
+
+package() {
+ cd ${srcdir}/R*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}