summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Delaney2020-09-18 20:34:11 -0400
committerRyan Delaney2020-09-18 20:34:11 -0400
commitfc3e30ab51ccbb8bdca348ff555d8c707e24a237 (patch)
treeb80ee89fe5eecabdec18c7fdc19d16c8a22d4f8b
parent0e82afe1ecf01448ca7e2d8b8f7c263310cb0afa (diff)
downloadaur-fc3e30ab51ccbb8bdca348ff555d8c707e24a237.tar.gz
Remove unnecessary dependencies
See https://wiki.archlinux.org/index.php/Font_package_guidelines#Dependencies > Fonts do not depend on anything. Many packages in the repositories, > however, include fontconfig and xorg-mkfontscale as dependecies. Those > were required when font packages needed to use install scripts to update > the font cache – a lot of duplicate work now done by pacman hooks. If > you install fontconfig or xorg-mkfontscale, all existing fonts in > /usr/share/fonts/ will be cached making it unnecessary to force people > to use fontconfig or mkfontscale.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83878d2bd975..44d7d931ada5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@ provides=('ttf-inconsolata-g')
pkgdesc="Monospace font for pretty code listings and for the terminal modified by Leonardo Maffi (http://www.fantascienza.net/leonardo/)"
url="http://levien.com/type/myfonts/inconsolata.html"
license=('unknown')
-depends=('fontconfig' 'xorg-font-utils')
+depends=()
source=('http://www.fantascienza.net/leonardo/ar/inconsolatag/inconsolata-g_font.zip')
install=ttf-inconsolata-g.install
arch=('any')
md5sums=('c36e53cb9022f8096fb78a0aae00cbb0')
-
+
package() {
install -Dm644 $srcdir/Inconsolata-g.ttf $pkgdir/usr/share/fonts/TTF/ttf-inconsolata-g.ttf
}