summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commitb98105c9b6869a38acaa11e24476eca122b752cc (patch)
treee3bbbcb3b3a6007614f634fd9763c0c99bd8abf6
downloadaur-b98105c9b6869a38acaa11e24476eca122b752cc.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--LICENSE10
-rw-r--r--PKGBUILD23
-rw-r--r--ttf-ingleby.install13
5 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..343dde005108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-ingleby
+ pkgdesc = Ingleby font from dafont.com
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.dafont.com/ingleby.font
+ install = ttf-ingleby.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = ttf-ingleby.zip::http://img.dafont.com/dl/?f=ingleby
+ source = LICENSE
+ md5sums = efe53e9821d831bf7f41c94e582e9a86
+ md5sums = 5f283b3761250226c5f1316d85cf0265
+
+pkgname = ttf-ingleby
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b32c247cdd4e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,10 @@
+Ingleby by David Engelby
+
+Note of the author
+This font, Ingleby, is free for personal use. For other commercial usage Ingleby is also free.
+
+IMPORTANT NOTE: If you intend to use the font Ingleby for print media or digital media, I want to
+be listed in a relevant colophon as the designer of the font Ingleby. The following text must be
+used in a colophon:
+The typeface Ingleby is designed by David Engelby and is available at dafont.com. David Engelby has
+the creative, intellectual ownership of the original design of Ingleby.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9fce6c4541e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Anton Leontiev <bunder /at/ t-25.ru>
+
+pkgname=ttf-ingleby
+pkgver=1.0
+pkgrel=1
+pkgdesc="Ingleby font from dafont.com"
+arch=('any')
+url="http://www.dafont.com/ingleby.font"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=($pkgname.zip::http://img.dafont.com/dl/?f=ingleby 'LICENSE')
+md5sums=('efe53e9821d831bf7f41c94e582e9a86'
+ '5f283b3761250226c5f1316d85cf0265')
+
+build() {
+ cd $srcdir
+ install -Dm644 Ingleby_regular.ttf $pkgdir/usr/share/fonts/TTF/Ingleby_regular.ttf
+ install -Dm644 Ingleby_italic.ttf $pkgdir/usr/share/fonts/TTF/Ingleby_italic.ttf
+ install -Dm644 Ingleby_bold.ttf $pkgdir/usr/share/fonts/TTF/Ingleby_bold.ttf
+ install -Dm644 Ingleby_bold_italic.ttf $pkgdir/usr/share/fonts/TTF/Ingleby_bold_italic.ttf
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/ttf-ingleby/LICENSE
+}
diff --git a/ttf-ingleby.install b/ttf-ingleby.install
new file mode 100644
index 000000000000..2cb9e68b86ff
--- /dev/null
+++ b/ttf-ingleby.install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}