summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Weimar2019-08-25 09:41:26 +0200
committerMarkus Weimar2019-08-25 09:41:26 +0200
commite5cba133da3aa1a97c41323c8776c3f63ad74a16 (patch)
tree0aae23693a6658ef71235f00e357cfb272fcb18a
downloadaur-e5cba133da3aa1a97c41323c8776c3f63ad74a16.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c34df60d7f46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-iosevka-etoile
+ pkgdesc = Experimental, quasi-proportional, slab-serif family of Iosevka.
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://be5invis.github.io/Iosevka/
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = ttf-iosevka-pack
+ source = https://github.com/be5invis/Iosevka/releases/download/v2.3.0/experimental-iosevka-etoile-2.3.0.zip
+ source = ttf-iosevka-etoile-2.3.0-1-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/master/LICENSE.md
+ sha256sums = 72045d83118b8454c05ce415d48eb698e86c0a39a8a36efc63abcc3519207591
+ sha256sums = ecfd74a1d6749bf509cee122870da0186bccfae446e3f6bc5faff253577ab000
+
+pkgname = ttf-iosevka-etoile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd21a1819a38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-etoile
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Experimental, quasi-proportional, slab-serif family of Iosevka.'
+arch=('any')
+url='https://be5invis.github.io/Iosevka/'
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-iosevka-pack')
+source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/experimental-iosevka-etoile-${pkgver}.zip"
+ "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/master/LICENSE.md")
+sha256sums=('1844aa8221f91f5171ebe8f1b60b156179bef7752fec22848b588d897e523be1'
+ 'ecfd74a1d6749bf509cee122870da0186bccfae446e3f6bc5faff253577ab000')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/${pkgname}
+ install -m644 ${srcdir}/ttf/*.ttf ${pkgdir}/usr/share/fonts/${pkgname}
+ install -D -m644 ${pkgname}-${pkgver}-${pkgrel}-LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
+}