summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2017-02-23 16:12:03 -0500
committerAndy Kluger2017-02-23 16:12:03 -0500
commit23e8c07130a8cc2d7ff239e5f80bff69d77e7698 (patch)
tree64f9e19c5f19885bd73e4ff0f417d4499505900d
downloadaur-23e8c07130a8cc2d7ff239e5f80bff69d77e7698.tar.gz
nothing fancy, just compile from git
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e2613625f5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ttf-iosevka-git
+ pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
+ pkgver = r906.695db24
+ pkgrel = 1
+ url = https://be5invis.github.io/Iosevka/
+ arch = any
+ license = custom:OFL
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ makedepends = ttfautohint
+ makedepends = otfcc
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-iosevka
+ conflicts = ttf-iosevka-hooky
+ conflicts = ttf-iosevka-zshaped
+ conflicts = ttf-iosevka
+ conflicts = ttf-iosevka-custom-git
+ source = git+https://github.com/be5invis/Iosevka
+ md5sums = SKIP
+
+pkgname = ttf-iosevka-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98f34ebc2178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Contributor: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-git
+pkgver=r906.695db24
+pkgrel=1
+pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
+arch=('any')
+url='https://be5invis.github.io/Iosevka/'
+license=('custom:OFL')
+makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-iosevka-hooky' 'ttf-iosevka-zshaped' 'ttf-iosevka' 'ttf-iosevka-custom-git')
+provides=('ttf-iosevka')
+source=("git+https://github.com/be5invis/Iosevka")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "Iosevka"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Iosevka
+ npm install
+ make
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 Iosevka/dist/*/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 Iosevka/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/"
+}