summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-03-06 01:25:18 -0500
committerAndy Kluger2020-03-06 01:25:18 -0500
commit957e110b230fdea40f484788837701c240c114d5 (patch)
tree880c5df3326bd4769922f465d5e9a4c0dd76cf9e
parent4034a47803799f0e080e841cbba60b8130f66461 (diff)
downloadaur-957e110b230fdea40f484788837701c240c114d5.tar.gz
include disabled G-patch; update node modules; seems to build ok despite gyp error, see open issue on iosevka's tracker
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
-rw-r--r--toothless-G.patch32
4 files changed, 54 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8130052a2e76..de0d5e9393d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,9 @@ pkgbase = ttf-iosevka-git
provides = ttf-iosevka
conflicts = ttf-iosevka
source = git+https://github.com/be5invis/Iosevka
- md5sums = SKIP
+ source = toothless-G.patch
+ sha256sums = SKIP
+ sha256sums = 56d1d97b421ab462d71875ecadf57d65ee45fe26edee50922ae9ae96350cff52
pkgname = ttf-iosevka-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 218620e2fb38..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!/PKGBUILD
-!/.SRCINFO
-!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 73996220540c..43a73248b02f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,34 @@ makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
depends=('fontconfig' 'xorg-font-utils')
conflicts=('ttf-iosevka')
provides=('ttf-iosevka')
-source=("git+https://github.com/be5invis/Iosevka")
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/be5invis/Iosevka'
+ 'toothless-G.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '56d1d97b421ab462d71875ecadf57d65ee45fe26edee50922ae9ae96350cff52'
+)
pkgver() {
cd Iosevka
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd Iosevka
+
+ # patch -p1 < ../toothless-G.patch
+
+ # Uncomment the above line to get back the smoother capital G,
+ # as seen in this image (look for "LIGHT"):
+ # https://raw.githubusercontent.com/be5invis/Iosevka/47023ab4058987f58844f6308d8175e735106b8a/images/preview-all.png
+}
+
build() {
cd Iosevka
npm install
+ npm update
npm run build -- ttf::iosevka
}
diff --git a/toothless-G.patch b/toothless-G.patch
new file mode 100644
index 000000000000..3e8f1fd61118
--- /dev/null
+++ b/toothless-G.patch
@@ -0,0 +1,32 @@
+diff --git a/glyphs/letters-unified-basic.ptl b/glyphs/letters-unified-basic.ptl
+index 40fb8784..5cd2ffae 100644
+--- a/glyphs/letters-unified-basic.ptl
++++ b/glyphs/letters-unified-basic.ptl
+@@ -2753,8 +2753,6 @@ export : define [apply] : begin
+ do "G and related ============================================================================="
+ define [GShape top sma smb] : glyph-construction
+ local yBar : top * 0.52 + STROKE * 0.25
+- local fine SHOULDERFINE
+- local sb : shoulderMidSlope fine nothing (-1)
+ include : dispiro
+ widths.lhs
+ g4 RIGHTSB (top - HOOK)
+@@ -2762,12 +2760,13 @@ export : define [apply] : begin
+ flat (SB + OX) (top - sma)
+ curl (SB + OX) smb
+ arcvh
+- g4.right.mid (MIDDLE + (CORRECTION_OMIDX - sb) * STROKE) O [widths.heading STROKE 0 {.y (1) .x (sb)}]
++ g4 (MIDDLE + CORRECTION_OMIDS) O
+ archv
+- straight.up.end (RIGHTSB - (STROKE - fine) * HVCONTRAST) sma [widths.heading fine 0 UPWARD]
+- include : HBarTop MIDDLE RIGHTSB yBar
+- include : VBarRight RIGHTSB sma yBar
+- include : VBarRight RIGHTSB sma 0 (STROKE - fine / 2)
++ flat RIGHTSB sma
++ curl RIGHTSB yBar [heading UPWARD]
++ include : dispiro
++ flat MIDDLE yBar [widths 0 STROKE]
++ curl RIGHTSB yBar [heading RIGHTWARD]
+
+ sketch # G
+ set-width WIDTH