summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2018-10-10 22:41:17 -0400
committerAndy Kluger2018-10-10 22:41:17 -0400
commita2f6a4d4398eeb674e1f31a1a11e1629c51c34df (patch)
tree93e2f87d9f9682f12f91e362bc87835fd488d24c
parent12ff9471f8ccd48c8c5735089c237e8560f19a09 (diff)
downloadaur-a2f6a4d4398eeb674e1f31a1a11e1629c51c34df.tar.gz
revert hacks to ensure a shallow checkout, and revert versioning scheme
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3097dc45b3..fa0e416e06c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-iosevka-git
pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
- pkgver = 2018.10.05T06.46.02Z.68b55c13
+ pkgver = r1145.68b55c13
pkgrel = 1
url = https://be5invis.github.io/Iosevka/
arch = any
@@ -14,6 +14,8 @@ pkgbase = ttf-iosevka-git
depends = xorg-font-utils
provides = ttf-iosevka
conflicts = ttf-iosevka
+ source = git+https://github.com/be5invis/Iosevka
+ md5sums = SKIP
pkgname = ttf-iosevka-git
diff --git a/PKGBUILD b/PKGBUILD
index 9490ba155305..1b9e852f48bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Kluger <AndyKluger@gmail.com>
# Contributor: Markus Weimar <mail@markusweimar.de>
pkgname=ttf-iosevka-git
-pkgver=2018.10.05T06.46.02Z.68b55c13
+pkgver=r1145.68b55c13
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
@@ -11,18 +11,12 @@ makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
depends=('fontconfig' 'xorg-font-utils')
conflicts=('ttf-iosevka')
provides=('ttf-iosevka')
-source=()
-md5sums=()
+source=("git+https://github.com/be5invis/Iosevka")
+md5sums=('SKIP')
pkgver() {
- commits=$(curl --silent https://api.github.com/repos/be5invis/Iosevka/commits)
- tstamp=$(printf "$commits" | grep '\s*"date":' | head -1 | cut -d '"' -f 4 | sed -E 's/-|:/./g')
- short_sha=$(printf "$commits" | grep '\s*"sha":' | head -1 | cut -d '"' -f 4 | cut -c -8)
- printf "$tstamp.$short_sha"
-}
-
-prepare() {
- git clone --depth=1 https://github.com/be5invis/Iosevka
+ cd "Iosevka"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {