summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Dainese2020-11-10 04:56:07 +0100
committerFrancesco Dainese2020-11-10 04:56:07 +0100
commit2624dd527673de4f3b4f0f4bd3e871061f634092 (patch)
treece5b0b04341a3773c56b261887ef21adb30ea667
downloadaur-2624dd527673de4f3b4f0f4bd3e871061f634092.tar.gz
Initial commit. Version 3.7.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d47c8628f25e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-iosevka-ss02-term
+ pkgdesc = Typeface family designed for coding, terminal use and technical documents.
+ pkgver = 3.7.1
+ pkgrel = 1
+ url = https://typeof.net/Iosevka/
+ arch = any
+ license = OFL
+ source = https://github.com/be5invis/Iosevka/releases/download/v3.7.1/ttf-iosevka-term-ss02-3.7.1.zip
+ source = ttf-iosevka-ss02-term-3.7.1-1-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v3.7.1/LICENSE.md
+ sha256sums = f2769fde0a2a28c8324cf8d885a8f0153b49c88eed6428aeb5b8da480f34c7b2
+ sha256sums = e61c0988bb231a321f14cce1b119a468f279ea86826c32e943ab16dbf08c1ba9
+
+pkgname = ttf-iosevka-ss02-term
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d9bf0fd8e97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Karrq
+# base: https://aur.archlinux.org/packages/ttf-iosevka-term/
+pkgname=ttf-iosevka-ss02-term
+pkgver=3.7.1
+pkgrel=1
+pkgdesc='Typeface family designed for coding, terminal use and technical documents.'
+arch=('any')
+url='https://typeof.net/Iosevka/'
+license=('OFL')
+source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/ttf-iosevka-term-ss02-${pkgver}.zip"
+ "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v${pkgver}/LICENSE.md")
+sha256sums=('f2769fde0a2a28c8324cf8d885a8f0153b49c88eed6428aeb5b8da480f34c7b2'
+ 'e61c0988bb231a321f14cce1b119a468f279ea86826c32e943ab16dbf08c1ba9')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 ttf/*.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -D -m644 ${pkgname}-${pkgver}-${pkgrel}-LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
+}