summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Weimar2021-05-29 16:44:58 +0200
committerMarkus Weimar2021-05-29 16:44:58 +0200
commit80bb0d1cdda51f1ea49132b32fbe5757172151ec (patch)
tree52fbf5cd7eee4ac628da3f227ab5c91ccce9a8bb
downloadaur-80bb0d1cdda51f1ea49132b32fbe5757172151ec.tar.gz
Initial commit. Version 7.0.0.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d81468f5ea2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-iosevka-ss18
+ pkgdesc = Typeface family designed for coding, terminal use and technical documents.
+ pkgver = 7.0.0
+ pkgrel = 1
+ url = https://typeof.net/Iosevka/
+ arch = any
+ license = OFL
+ source = https://github.com/be5invis/Iosevka/releases/download/v7.0.0/ttf-iosevka-ss18-7.0.0.zip
+ source = ttf-iosevka-ss18-7.0.0-1-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v7.0.0/LICENSE.md
+ sha256sums = 75150b9076bf4ef42a413306234bc35e3c9593f87b3f7556cc4ec1574e3212dd
+ sha256sums = 72c3d557ff41d871680652f56afd565ba6834c90eadc45a4ec15410dce1c0c80
+
+pkgname = ttf-iosevka-ss18
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..281721bd3143
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-ss18
+pkgver=7.0.0
+pkgrel=1
+pkgdesc='Typeface family designed for coding, terminal use and technical documents.'
+arch=('any')
+url='https://typeof.net/Iosevka/'
+license=('OFL')
+source=("https://github.com/be5invis/Iosevka/releases/download/v${pkgver}/ttf-iosevka-ss18-${pkgver}.zip"
+ "${pkgname}-${pkgver}-${pkgrel}-LICENSE.md::https://raw.githubusercontent.com/be5invis/Iosevka/v${pkgver}/LICENSE.md")
+sha256sums=('75150b9076bf4ef42a413306234bc35e3c9593f87b3f7556cc4ec1574e3212dd'
+ '72c3d557ff41d871680652f56afd565ba6834c90eadc45a4ec15410dce1c0c80')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -D -m644 ${pkgname}-${pkgver}-${pkgrel}-LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
+}