summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-11-09 22:39:08 -0500
committerAndy Kluger2020-11-09 22:39:08 -0500
commitd71309d161a5535c2665976bba36e3fc92379fe4 (patch)
tree579569983a207107c04005d5c007e59e7a957f0d
parent00cbb8b4e1d67b66b8557aed13704561f549b647 (diff)
downloadaur-d71309d161a5535c2665976bba36e3fc92379fe4.tar.gz
new config format for iosevka v4
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD17
-rw-r--r--private-build-plans.toml.example488
4 files changed, 336 insertions, 177 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c827528153c..2db842481778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ttf-iosevka-term-custom-git
pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
- pkgver = r2050.075dd6e4
+ pkgver = r2089.115f5b19
pkgrel = 1
url = https://be5invis.github.io/Iosevka/
arch = any
license = custom:OFL
makedepends = git
- makedepends = nodejs
+ makedepends = nodejs>=12.16.0
makedepends = npm
makedepends = ttfautohint
provides = ttf-iosevka-term-custom
@@ -15,7 +15,7 @@ pkgbase = ttf-iosevka-term-custom-git
source = git+https://github.com/be5invis/Iosevka
source = private-build-plans.toml.example
sha256sums = SKIP
- sha256sums = af64725b342f402bedf6338343a6983f7b5c36a0a6ac2ecae1d492613956f9eb
+ sha256sums = 132530ab6290715e1b31b7743c13e8e06af2df189739bf5ef29d3558f615a154
pkgname = ttf-iosevka-term-custom-git
diff --git a/.gitignore b/.gitignore
index 43cd644d16f1..763ffff9ce1b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/ttf-iosevka-term-custom-git-*.pkg.*
+/*.pkg.*
/src
/pkg
/Iosevka
diff --git a/PKGBUILD b/PKGBUILD
index ca6823a639f1..1def80d775fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Maintainer: Andy Kluger <https://t.me/andykluger>
# Contributor: Markus Weimar <mail@markusweimar.de>
-pkgname=ttf-iosevka-term-custom-git
-pkgver=r2050.075dd6e4
+_pkgname=ttf-iosevka-term-custom
+pkgname=${_pkgname}-git
+pkgver=r2089.115f5b19
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
url='https://be5invis.github.io/Iosevka/'
license=('custom:OFL')
-makedepends=('git' 'nodejs' 'npm' 'ttfautohint')
+makedepends=('git' 'nodejs>=12.16.0' 'npm' 'ttfautohint')
depends=()
-conflicts=('ttf-iosevka-term-custom')
-provides=('ttf-iosevka-term-custom')
+conflicts=(${_pkgname})
+provides=(${_pkgname})
replaces=('ttf-iosevka-termlig-custom-git')
source=(
'git+https://github.com/be5invis/Iosevka'
@@ -18,7 +19,7 @@ source=(
)
sha256sums=(
'SKIP'
- 'af64725b342f402bedf6338343a6983f7b5c36a0a6ac2ecae1d492613956f9eb'
+ '132530ab6290715e1b31b7743c13e8e06af2df189739bf5ef29d3558f615a154'
)
pkgver() {
@@ -40,7 +41,7 @@ build() {
cd Iosevka
npm install
npm update
- npm run build -- ttf::iosevka-term-custom
+ npm run build -- ttf::${_pkgname#*-}
}
package() {
diff --git a/private-build-plans.toml.example b/private-build-plans.toml.example
index 5de9b2ed4a7d..daac90752e33 100644
--- a/private-build-plans.toml.example
+++ b/private-build-plans.toml.example
@@ -1,165 +1,323 @@
-# docs:
-# https://github.com/be5invis/Iosevka/blob/master/private-build-plans.sample.toml
-# https://github.com/be5invis/Iosevka
-# https://github.com/be5invis/Iosevka#build-your-own-style
-
-# ss## stylistic sets:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/stylesets.png
-
-# cv## and VX__ character variants:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/charvars.png
-
-# ligset-* ligature sets:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/ligations.png
-
-[buildPlans.iosevka-custom] # Plan name
-family = "Iosevka Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv23", # lower ¶
- "cv24", # open double story g
- "cv26", # short legged m
- "cv27", # tailed l
- "cv33", # short @
- "cv46", # flat top 3
- "cv53", # tailed f
- "cv54", # open short $
- "cv60", # hex *
- "cv69", # curly kK
- "cv72", # curly vV
- "cv74", # curly A
- "cv76", # curly wW
- "cv78", # curly xX
- "cv79", # curly y
- "cv81", # curly Y
- "cv83", # curly R
- "cv90", # toothless u
- "cv92", # toothless G
- "cv93", # backslash 0
- "cv95", # curly λ
- "cv98", # sans j
- "VXAF", # open curved 6
- "VXAL", # flat top &
- "VXAT", # semi open 4
- "VXAQ", # bottom heavy B
- "VXBC", # straight 9
- "VXBE", # crossed zZ
- "VXBH", # rounder D
- "VXBL", # toothless cornered b
- "VXBQ", # tailed d
- "VXBU", # tailed a
- "VXBY", # hatless J
- "VXCA", # crossing Q
- "VXCT", # cornered tailed q
- "VXDH", # comma-like '
- "VXDP", # cornered tailed n
- "VXDS", # cornered r
-
-]
-
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-fixed-custom] # Plan name
-family = "Iosevka Fixed Custom" # Font menu family name
-design = [ # Common styles
-
- "sp-fixed", # strict mono; no ligatures
-
- "cv05", # hooky i
- "cv23", # lower ¶
- "cv24", # open double story g
- "cv26", # short legged m
- "cv27", # tailed l
- "cv33", # short @
- "cv46", # flat top 3
- "cv53", # tailed f
- "cv54", # open short $
- "cv60", # hex *
- "cv69", # curly kK
- "cv72", # curly vV
- "cv74", # curly A
- "cv76", # curly wW
- "cv78", # curly xX
- "cv79", # curly y
- "cv81", # curly Y
- "cv83", # curly R
- "cv90", # toothless u
- "cv92", # toothless G
- "cv93", # backslash 0
- "cv95", # curly λ
- "cv98", # sans j
- "VXAF", # open curved 6
- "VXAL", # flat top &
- "VXAT", # semi open 4
- "VXAQ", # bottom heavy B
- "VXBC", # straight 9
- "VXBE", # crossed zZ
- "VXBH", # rounder D
- "VXBL", # toothless cornered b
- "VXBQ", # tailed d
- "VXBU", # tailed a
- "VXBY", # hatless J
- "VXCA", # crossing Q
- "VXCT", # cornered tailed q
- "VXDH", # comma-like '
- "VXDP", # cornered tailed n
- "VXDS", # cornered r
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-term-custom] # Plan name
-family = "Iosevka Term Custom" # Font menu family name
-design = [ # Common styles
-
- "sp-term", # strict mono; with ligatures
-
- "cv05", # hooky i
- "cv23", # lower ¶
- "cv24", # open double story g
- "cv26", # short legged m
- "cv27", # tailed l
- "cv33", # short @
- "cv46", # flat top 3
- "cv53", # tailed f
- "cv54", # open short $
- "cv60", # hex *
- "cv69", # curly kK
- "cv72", # curly vV
- "cv74", # curly A
- "cv76", # curly wW
- "cv78", # curly xX
- "cv79", # curly y
- "cv81", # curly Y
- "cv83", # curly R
- "cv90", # toothless u
- "cv92", # toothless G
- "cv93", # backslash 0
- "cv95", # curly λ
- "cv98", # sans j
- "VXAF", # open curved 6
- "VXAL", # flat top &
- "VXAT", # semi open 4
- "VXAQ", # bottom heavy B
- "VXBC", # straight 9
- "VXBE", # crossed zZ
- "VXBH", # rounder D
- "VXBL", # toothless cornered b
- "VXBQ", # tailed d
- "VXBU", # tailed a
- "VXBY", # hatless J
- "VXCA", # crossing Q
- "VXCT", # cornered tailed q
- "VXDH", # comma-like '
- "VXDP", # cornered tailed n
- "VXDS", # cornered r
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
+[buildPlans.iosevka-custom]
+family = "Iosevka Custom"
+
+# [buildPlans.iosevka-custom.variants]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#stylistic-sets
+# inherits = "ss14"
+
+[buildPlans.iosevka-custom.variants.design]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-character-variants
+# https://github.com/be5invis/Iosevka/raw/dev-v4/images/charvars.png
+turn-v = "curly"
+capital-b = "more-asymmetric"
+capital-d = "more-rounded"
+capital-g = "toothless"
+capital-j = "serifless"
+capital-k = "curly"
+capital-m = "hanging"
+capital-q = "crossing"
+capital-r = "curly"
+capital-y = "curly"
+a = "doublestorey-tailed"
+b = "toothless-corner"
+d = "tailed"
+f = "tailed"
+g = "opendoublestorey"
+h = "straight"
+i = "hooky"
+j = "straight"
+k = "curly"
+l = "tailed"
+m = "shortleg"
+n = "earless-corner-tailed"
+p = "eared"
+q = "earless-corner-tailed"
+r = "earless-corner"
+t = "standard"
+u = "toothless-rounded"
+v = "curly"
+w = "curly"
+x = "curly"
+y = "curly"
+z = "with-crossbar"
+eszet = "longs-s-lig"
+lambda = "curly"
+zero = "reverse-slashed"
+one = "nobase"
+three = "flattop"
+four = "semi-open"
+six = "open-contour"
+seven = "noserif"
+nine = "straight-bar"
+tilde = "low"
+asterisk = "hexhigh"
+underscore = "high"
+paragraph-sign = "low"
+caret = "high"
+paren = "normal"
+brace = "curly"
+number-sign = "upright"
+ampersand = "flat-top"
+at = "short"
+dollar = "opencap"
+percent = "rings"
+bar = "v-bar-natural-slope"
+lig-ltgteq = "flat"
+ascii-single-quote = "raised-comma"
+ascii-grave = "straight"
+
+# Override above variants for each slope:
+# [buildPlans.iosevka-custom.variants.upright]
+# [buildPlans.iosevka-custom.variants.italic]
+# [buildPlans.iosevka-custom.variants.oblique]
+
+# [buildPlans.iosevka-custom.ligations]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-ligations
+# https://github.com/be5invis/Iosevka/tree/dev-v4#ligations
+# inherits = "calt"
+# disables = []
+# enables = []
+
+[buildPlans.iosevka-term-custom]
+family = "Iosevka Term Custom"
+spacing = "term"
+
+# [buildPlans.iosevka-term-custom.variants]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#stylistic-sets
+# inherits = "ss14"
+
+[buildPlans.iosevka-term-custom.variants.design]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-character-variants
+# https://github.com/be5invis/Iosevka/raw/dev-v4/images/charvars.png
+turn-v = "curly"
+capital-b = "more-asymmetric"
+capital-d = "more-rounded"
+capital-g = "toothless"
+capital-j = "serifless"
+capital-k = "curly"
+capital-m = "hanging"
+capital-q = "crossing"
+capital-r = "curly"
+capital-y = "curly"
+a = "doublestorey-tailed"
+b = "toothless-corner"
+d = "tailed"
+f = "tailed"
+g = "opendoublestorey"
+h = "straight"
+i = "hooky"
+j = "straight"
+k = "curly"
+l = "tailed"
+m = "shortleg"
+n = "earless-corner-tailed"
+p = "eared"
+q = "earless-corner-tailed"
+r = "earless-corner"
+t = "standard"
+u = "toothless-rounded"
+v = "curly"
+w = "curly"
+x = "curly"
+y = "curly"
+z = "with-crossbar"
+eszet = "longs-s-lig"
+lambda = "curly"
+zero = "reverse-slashed"
+one = "nobase"
+three = "flattop"
+four = "semi-open"
+six = "open-contour"
+seven = "noserif"
+nine = "straight-bar"
+tilde = "low"
+asterisk = "hexhigh"
+underscore = "high"
+paragraph-sign = "low"
+caret = "high"
+paren = "normal"
+brace = "curly"
+number-sign = "upright"
+ampersand = "flat-top"
+at = "short"
+dollar = "opencap"
+percent = "rings"
+bar = "v-bar-natural-slope"
+lig-ltgteq = "flat"
+ascii-single-quote = "raised-comma"
+ascii-grave = "straight"
+
+# Override above variants for each slope:
+# [buildPlans.iosevka-term-custom.variants.upright]
+# [buildPlans.iosevka-term-custom.variants.italic]
+# [buildPlans.iosevka-term-custom.variants.oblique]
+
+# [buildPlans.iosevka-term-custom.ligations]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-ligations
+# https://github.com/be5invis/Iosevka/tree/dev-v4#ligations
+# inherits = "calt"
+# disables = []
+# enables = []
+
+[buildPlans.iosevka-force-monospace-custom]
+family = "Iosevka Force Monospace Custom"
+spacing = "force-monospace"
+
+# [buildPlans.iosevka-force-monospace-custom.variants]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#stylistic-sets
+# inherits = "ss14"
+
+[buildPlans.iosevka-force-monospace-custom.variants.design]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-character-variants
+# https://github.com/be5invis/Iosevka/raw/dev-v4/images/charvars.png
+turn-v = "curly"
+capital-b = "more-asymmetric"
+capital-d = "more-rounded"
+capital-g = "toothless"
+capital-j = "serifless"
+capital-k = "curly"
+capital-m = "hanging"
+capital-q = "crossing"
+capital-r = "curly"
+capital-y = "curly"
+a = "doublestorey-tailed"
+b = "toothless-corner"
+d = "tailed"
+f = "tailed"
+g = "opendoublestorey"
+h = "straight"
+i = "hooky"
+j = "straight"
+k = "curly"
+l = "tailed"
+m = "shortleg"
+n = "earless-corner-tailed"
+p = "eared"
+q = "earless-corner-tailed"
+r = "earless-corner"
+t = "standard"
+u = "toothless-rounded"
+v = "curly"
+w = "curly"
+x = "curly"
+y = "curly"
+z = "with-crossbar"
+eszet = "longs-s-lig"
+lambda = "curly"
+zero = "reverse-slashed"
+one = "nobase"
+three = "flattop"
+four = "semi-open"
+six = "open-contour"
+seven = "noserif"
+nine = "straight-bar"
+tilde = "low"
+asterisk = "hexhigh"
+underscore = "high"
+paragraph-sign = "low"
+caret = "high"
+paren = "normal"
+brace = "curly"
+number-sign = "upright"
+ampersand = "flat-top"
+at = "short"
+dollar = "opencap"
+percent = "rings"
+bar = "v-bar-natural-slope"
+lig-ltgteq = "flat"
+ascii-single-quote = "raised-comma"
+ascii-grave = "straight"
+
+# Override above variants for each slope:
+# [buildPlans.iosevka-force-monospace-custom.variants.upright]
+# [buildPlans.iosevka-force-monospace-custom.variants.italic]
+# [buildPlans.iosevka-force-monospace-custom.variants.oblique]
+
+# [buildPlans.iosevka-force-monospace-custom.ligations]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-ligations
+# https://github.com/be5invis/Iosevka/tree/dev-v4#ligations
+# inherits = "calt"
+# disables = []
+# enables = []
+
+[buildPlans.iosevka-fixed-custom]
+family = "Iosevka Fixed Custom"
+spacing = "fixed"
+
+# [buildPlans.iosevka-fixed-custom.variants]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#stylistic-sets
+# inherits = "ss14"
+
+[buildPlans.iosevka-fixed-custom.variants.design]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-character-variants
+# https://github.com/be5invis/Iosevka/raw/dev-v4/images/charvars.png
+turn-v = "curly"
+capital-b = "more-asymmetric"
+capital-d = "more-rounded"
+capital-g = "toothless"
+capital-j = "serifless"
+capital-k = "curly"
+capital-m = "hanging"
+capital-q = "crossing"
+capital-r = "curly"
+capital-y = "curly"
+a = "doublestorey-tailed"
+b = "toothless-corner"
+d = "tailed"
+f = "tailed"
+g = "opendoublestorey"
+h = "straight"
+i = "hooky"
+j = "straight"
+k = "curly"
+l = "tailed"
+m = "shortleg"
+n = "earless-corner-tailed"
+p = "eared"
+q = "earless-corner-tailed"
+r = "earless-corner"
+t = "standard"
+u = "toothless-rounded"
+v = "curly"
+w = "curly"
+x = "curly"
+y = "curly"
+z = "with-crossbar"
+eszet = "longs-s-lig"
+lambda = "curly"
+zero = "reverse-slashed"
+one = "nobase"
+three = "flattop"
+four = "semi-open"
+six = "open-contour"
+seven = "noserif"
+nine = "straight-bar"
+tilde = "low"
+asterisk = "hexhigh"
+underscore = "high"
+paragraph-sign = "low"
+caret = "high"
+paren = "normal"
+brace = "curly"
+number-sign = "upright"
+ampersand = "flat-top"
+at = "short"
+dollar = "opencap"
+percent = "rings"
+bar = "v-bar-natural-slope"
+lig-ltgteq = "flat"
+ascii-single-quote = "raised-comma"
+ascii-grave = "straight"
+
+# Override above variants for each slope:
+# [buildPlans.iosevka-fixed-custom.variants.upright]
+# [buildPlans.iosevka-fixed-custom.variants.italic]
+# [buildPlans.iosevka-fixed-custom.variants.oblique]
+
+# [buildPlans.iosevka-fixed-custom.ligations]
+# https://github.com/be5invis/Iosevka/tree/dev-v4#configuring-ligations
+# https://github.com/be5invis/Iosevka/tree/dev-v4#ligations
+# inherits = "calt"
+# disables = []
+# enables = []
+