summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2017-05-10 16:03:19 -0400
committerAndy Kluger2017-05-10 16:03:19 -0400
commitded6c0e0bec5ec9b6b138ed97c8b6d6d6ec5ac1e (patch)
tree44898e729e0435075efe0d62bbf1f44946d26150
downloadaur-ded6c0e0bec5ec9b6b138ed97c8b6d6d6ec5ac1e.tar.gz
term style, for vte3 compatibility, though ligations are very sadly lost
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD97
2 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5634ee36b20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ttf-iosevka-term-custom-git
+ pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
+ pkgver = r991.79a6f89
+ pkgrel = 1
+ url = https://be5invis.github.io/Iosevka/
+ arch = any
+ license = custom:OFL
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ makedepends = ttfautohint
+ makedepends = otfcc
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-iosevka-term
+ conflicts = ttf-iosevka-term
+ conflicts = ttf-iosevka-term-hooky
+ conflicts = ttf-iosevka-term-zshaped
+ conflicts = ttf-iosevka-term-slab
+ source = git+https://github.com/be5invis/Iosevka
+ md5sums = SKIP
+
+pkgname = ttf-iosevka-term-custom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7219476284b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Contributor: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-term-custom-git
+pkgver=r991.79a6f89
+pkgrel=1
+pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
+arch=('any')
+url='https://be5invis.github.io/Iosevka/'
+license=('custom:OFL')
+makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=(ttf-iosevka-term{,-hooky,-zshaped,-slab})
+provides=('ttf-iosevka-term')
+source=("git+https://github.com/be5invis/Iosevka")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "Iosevka"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Iosevka
+ npm install
+ make custom-config design='term v-l-tailed v-i-hooky v-g-opendoublestorey v-m-shortleg v-zero-dotted'
+ make custom
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 Iosevka/dist/*/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 Iosevka/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/"
+ for font in "${pkgdir}"/usr/share/fonts/TTF/*; do
+ mv "$font" "${font%.*}-term.${font##*.}"
+ done
+}
+
+# letter l:
+# v-l-hooky : Hooky l.
+# v-l-zshaped : Z-shaped l.
+# v-l-serifed : Serifed l (default for upright and oblique).
+# v-l-italic : Italic l (default for italic).
+# v-l-tailed : l with a curved tail.
+# v-l-hookybottom : l with a straight tail.
+# letter i:
+# v-i-hooky : Hooky i.
+# v-i-zshaped : Z-shaped i.
+# v-i-serifed : Serifed i (default for upright and oblique).
+# v-i-italic : Italic i (default for italic).
+# letter a:
+# v-a-doublestorey : Double-storey a (default for upright and oblique).
+# v-a-singlestorey : Single-storey a (default for italic).
+# letter g:
+# v-g-doublestorey : Double-storey g (default).
+# v-g-singlestorey : Single-storey g.
+# v-g-opendoublestorey : Open Single-storey g.
+# letter m:
+# v-m-longleg : m with long middle leg (default).
+# v-m-shortleg : m with shorter middle leg.
+# letter t:
+# v-t-standard : Standard t shape (default).
+# v-t-cross : Futura-like t shape.
+# letter Q:
+# v-q-taily : Q with a curly tail (default).
+# v-q-straight : Q with a straight tail in the old versions.
+# zero (0):
+# v-zero-slashed : Slashed Zero 0 (default).
+# v-zero-dotted : Dotted Zero 0.
+# v-zero-unslashed : O-like 0.
+# ASCII tilde (~), asterisk (*), paragaraph(¶), underscore (_) and ASCII Caret (^):
+# v-tilde-high : Higher tilde ~.
+# v-tilde-low : Lower tilde ~ (default).
+# v-asterisk-high : Higher asterisk * (default).
+# v-asterisk-low : Lower asterisk *.
+# v-paragraph-high : Higher paragraph symbol ¶ (default).
+# v-paragraph-low : Lower paragraph symbol ¶.
+# v-caret-high : Higher circumflex ^ (default).
+# v-caret-low : Lower circumflex ^.
+# v-underscore-high : Higher underscore _ (default).
+# v-underscore-low : Lower underscore _.
+# At (@):
+# v-at-long : The long, three-fold At symbol in Iosevka 1.7.x.
+# v-at-fourfold : The traditional, four-fold At symbol.
+# v-at-short : The shorter, Fira-like At symbol introduced in Iosevka 1.8.
+# Eszet(ß)
+# v-eszet-traditional : Tratidional, Fraktur-like Eszet.
+# v-eszet-sulzbacher : A more modern, beta-like Eszet (default).
+# curly brackets ({})
+# v-brace-straight : More straight braces.
+# v-brace-curly : More curly braces (default).
+# dollar symbol ($):
+# v-dollar-open : Dollar symbol with open contour.
+# v-dollar-through : Dollar symbol with strike-through vertical bar (default).
+# Number sign (#):
+# v-numbersign-upright : Number sign with vertical bars (default).
+# v-numbersign-slanted : Number sign with slanted bars.