summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlurryFlurry2018-08-31 22:24:52 +0530
committerBlurryFlurry2018-08-31 22:24:52 +0530
commite26884b9f77806a61a2bdc59ba5d64750d011d6d (patch)
tree4446711dd6b2ec0b980a9cd6d9fd4e7d9a446c22
downloadaur-e26884b9f77806a61a2bdc59ba5d64750d011d6d.tar.gz
Version 1.0
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD18
-rwxr-xr-xttf-iskpota.install11
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a621ec2c981f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-iskpota
+ pkgdesc = Unicode sinhala font iskoola pota
+ pkgver = 1
+ pkgrel = 1
+ url = https://www.np.gov.lk
+ install = ttf-iskpota.install
+ arch = any
+ license = GPL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://www.np.gov.lk/iskpota.ttf
+ md5sums = eead4a342b44623239b39790a0cc88d2
+
+pkgname = ttf-iskpota
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..080c92653887
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Chanz Holopainen <chan at elakiri dot com>
+
+pkgname=ttf-iskpota
+pkgver=1
+pkgrel=1
+pkgdesc="Unicode sinhala font iskoola pota"
+arch=('any')
+url="https://www.np.gov.lk"
+license=('GPL')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=(https://www.np.gov.lk/iskpota.ttf)
+md5sums=('eead4a342b44623239b39790a0cc88d2')
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/fonts/TTF"
+ cp "${srcdir}/iskpota.ttf" "${pkgdir}/usr/share/fonts/TTF/iskpota.ttf"
+}
diff --git a/ttf-iskpota.install b/ttf-iskpota.install
new file mode 100755
index 000000000000..80e487f69895
--- /dev/null
+++ b/ttf-iskpota.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}