summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrash2015-08-25 12:46:49 +0200
committertrash2015-08-25 12:46:49 +0200
commitc64ab22d1ce9389aff8816e8fb1e51ea0a8f4fb6 (patch)
tree10e756ec41095dac38b536aee311c9605843a8fd
downloadaur-c64ab22d1ce9389aff8816e8fb1e51ea0a8f4fb6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--license8
-rw-r--r--ttf-keep-calm-medium.install15
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1d8c8a13b35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-keep-calm-medium
+ pkgdesc = A font developed from the now famous World War 2 poster.
+ pkgver = 1.2
+ pkgrel = 1
+ install = ttf-keep-calm-medium.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.k-type.com/freefonts/KEEP_CALM_MEDIUM.zip
+ source = license
+ md5sums = b53ffed6598fcfc48665f15cef6ead3d
+ md5sums = 3d96b169fb7d42077af1865825a00e89
+
+pkgname = ttf-keep-calm-medium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7830b0f2b531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=ttf-keep-calm-medium
+pkgver=1.2
+pkgrel=1
+pkgdesc="A font developed from the now famous World War 2 poster."
+arch=(any)
+license=(custom)
+depends=(fontconfig xorg-font-utils)
+source=("http://www.k-type.com/freefonts/KEEP_CALM_MEDIUM.zip" "license")
+md5sums=(b53ffed6598fcfc48665f15cef6ead3d 3d96b169fb7d42077af1865825a00e89)
+install=$pkgname.install
+
+package() {
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 "$srcdir/license" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "$srcdir/KEEP CALM MEDIUM/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
+
diff --git a/license b/license
new file mode 100644
index 000000000000..a725f6b3e440
--- /dev/null
+++ b/license
@@ -0,0 +1,8 @@
+K-Type Licence Agreement
+
+Free Fonts
+
+K-Type Free Fonts are provided free for personal use, you don’t require a
+licence to use them among your friends and family. However, free fonts used for
+business or promotional purposes, or as webfonts, need to be licensed by
+purchasing the appropriate Commercial Licence or Enterprise Licence.
diff --git a/ttf-keep-calm-medium.install b/ttf-keep-calm-medium.install
new file mode 100644
index 000000000000..c2f11b1d7317
--- /dev/null
+++ b/ttf-keep-calm-medium.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}