summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Korpel2015-06-10 21:06:51 +0200
committerMarcel Korpel2015-06-10 21:06:51 +0200
commit407c7e12d131183cbf9b8fa540ad850d96697829 (patch)
tree4f625675d7f048df5bfef81ba091b2bb5ea53aa9
downloadaur-407c7e12d131183cbf9b8fa540ad850d96697829.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
-rw-r--r--ttf-kix.install15
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c50dbdf7a88a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-kix
+ pkgdesc = The KIX code is a barcode-like format used by the Dutch Post to encode zip codes and street numbers in a machine-readable format (Royal Mail 4 State Code)
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.postnl.nl/klantenservice/bestellen-en-downloaden/documentatie-downloaden/kix-code/
+ install = ttf-kix.install
+ arch = any
+ license = unknown
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://www.postnl.nl/Images/KIX-font-brg-ttf-PostNL_tcm10-11662.zip
+ sha256sums = fa113518a3a4528b5a3960efa6a6a4fbd17836bca65d1ce626bb87f52e646b4f
+
+pkgname = ttf-kix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34f5f36e110d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+
+pkgname=ttf-kix
+pkgver=1
+pkgrel=1
+pkgdesc='The KIX code is a barcode-like format used by the Dutch Post to encode zip codes and street numbers in a machine-readable format (Royal Mail 4 State Code)'
+arch=('any')
+url='http://www.postnl.nl/klantenservice/bestellen-en-downloaden/documentatie-downloaden/kix-code/'
+license=('unknown')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=$pkgname.install
+source=('http://www.postnl.nl/Images/KIX-font-brg-ttf-PostNL_tcm10-11662.zip')
+sha256sums=('fa113518a3a4528b5a3960efa6a6a4fbd17836bca65d1ce626bb87f52e646b4f')
+
+package() {
+ install -Dm644 "${srcdir}/Kixbrg__.ttf" "${pkgdir}/usr/share/fonts/TTF/Kixbrg__.ttf"
+}
diff --git a/ttf-kix.install b/ttf-kix.install
new file mode 100644
index 000000000000..aca81bf3db0f
--- /dev/null
+++ b/ttf-kix.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}