summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-12 12:51:27 +0300
committerCaleb Maclennan2020-03-12 12:51:27 +0300
commit01bdaaa044b4c3c641d20b549e527fe582d557d9 (patch)
treee29a2f058c9ce7f17df7b4a732783fa7e5b1bba7
parent8381e6f9e01e09f8e81856b51820c214eb401bb8 (diff)
downloadaur-01bdaaa044b4c3c641d20b549e527fe582d557d9.tar.gz
Don't package OTF fonts in TTF package, drop obsolete dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f8b1133acff..a88d8a35adfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = ttf-knewave
- pkgdesc = A bold, painted face font for the rocker within.
+ pkgdesc = A bold, painted face font for the rocker within
pkgver = 20160215
- pkgrel = 2
+ pkgrel = 3
url = http://theleagueofmoveabletype.com/knewave
arch = any
groups = lmt-fonts
- license = custom:OFL
- depends = fontconfig
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
- source = ttf-knewave-20160215.zip::https://github.com/theleagueof/knewave/archive/master.zip
- md5sums = ec880e36c11c0a16b06be6cd5884e3b8
+ license = OFL
+ source = ttf-knewave-20160215.zip::https://github.com/theleagueof/knewave/archive/f335d5ff1f12e4acf97d4208e1c37b4d386e57fb.zip
+ sha256sums = e5fc9f85d929f2ddb678a55786a65cd63435d75e9f146e09aff07ca68eda52d9
pkgname = ttf-knewave
diff --git a/PKGBUILD b/PKGBUILD
index 5d0af0f07c52..b047f3dfbb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=knewave
pkgname=ttf-$_fnt_name
pkgver=20160215
-pkgrel=2
-pkgdesc="A bold, painted face font for the rocker within."
+_sha=f335d5ff1f12e4acf97d4208e1c37b4d386e57fb
+pkgrel=3
+pkgdesc='A bold, painted face font for the rocker within'
arch=('any')
url="http://theleagueofmoveabletype.com/$_fnt_name"
-license=('custom:OFL')
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
-md5sums=('ec880e36c11c0a16b06be6cd5884e3b8')
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
+sha256sums=('e5fc9f85d929f2ddb678a55786a65cd63435d75e9f146e09aff07ca68eda52d9')
package() {
- install -d "$pkgdir"/usr/share/fonts/OTF
- install -d "$pkgdir"/usr/share/fonts/TTF
- install -Dm644 "$srcdir/$_fnt_name"-master/*.otf "$pkgdir"/usr/share/fonts/OTF/
- install -Dm644 "$srcdir/$_fnt_name"-master/*.ttf "$pkgdir"/usr/share/fonts/TTF/
-
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}