summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlester2014-01-27 15:54:53 +0800
committerlester2014-01-27 15:58:19 +0800
commit2358f35ea71ce6c2f6be012fe38e31115ffc6a5f (patch)
tree39f9513bbf0a38a09f7090c9d602da03eec4f420
downloadaur-2358f35ea71ce6c2f6be012fe38e31115ffc6a5f.tar.gz
Create ttf-liberation-sans-narrow
In version 2.00.0 and greater, Liberation Sans Narrow was removed. In order to get the mentioned font, one need to get the previous release. This package will provide the removed font. The PKGBUILD is based on the ttf-liberation PKGBUILD in the Arch Linux repository.
-rw-r--r--.SRCINFO21
-rw-r--r--30-0-liberation-sans-narrow.conf18
-rw-r--r--PKGBUILD38
-rw-r--r--ttf.install16
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02c7805df0d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ttf-liberation-sans-narrow
+ pkgdesc = Red Hats Liberation fonts.
+ pkgver = 1.07.3
+ pkgrel = 1
+ url = https://www.redhat.com/promo/fonts/
+ install = ttf.install
+ arch = any
+ license = GPL2
+ makedepends = fontforge
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ optdepends = ttf-liberation: Main liberation fonts
+ provides = ttf-font
+ source = https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-1.07.3.tar.gz
+ source = 30-0-liberation-sans-narrow.conf
+ md5sums = b3174b11c2b6a341f5c99b31088bd67b
+ md5sums = c99ab610c6c6f1616417ff67f26624df
+
+pkgname = ttf-liberation-sans-narrow
+
diff --git a/30-0-liberation-sans-narrow.conf b/30-0-liberation-sans-narrow.conf
new file mode 100644
index 000000000000..a4f4da7e337d
--- /dev/null
+++ b/30-0-liberation-sans-narrow.conf
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
+<fontconfig>
+ <!-- Microsoft -->
+ <alias binding="same">
+ <family>Arial Narrow</family>
+ <accept>
+ <family>Liberation Sans Narrow</family>
+ </accept>
+ </alias>
+ <alias binding="same">
+ <family>Liberation Sans Narrow</family>
+ <default>
+ <family>Arial Narrow</family>
+ </default>
+ </alias>
+</fontconfig>
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd5e9fb2c9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+# Contributor: Lukas Fleischer <archlinux at cryptocrack dot de>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: Andreas Zwinkau
+# Contributor: rabyte <rabyte__gmail>
+# Contributor: Stefan Husmann < stefan-husmann@t-online.de>
+
+pkgname=ttf-liberation-sans-narrow
+pkgver=1.07.3
+pkgrel=1
+pkgdesc='Red Hats Liberation fonts.'
+arch=('any')
+license=('GPL2')
+url='https://www.redhat.com/promo/fonts/'
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+optdepends=('ttf-liberation: Main liberation fonts')
+makedepends=('fontforge')
+provides=('ttf-font')
+install=ttf.install
+source=("https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-$pkgver.tar.gz"
+ 30-0-liberation-sans-narrow.conf)
+md5sums=('b3174b11c2b6a341f5c99b31088bd67b'
+ 'c99ab610c6c6f1616417ff67f26624df')
+
+package() {
+ cd "$srcdir/liberation-fonts-ttf-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 LiberationSansNarrow*.ttf "$pkgdir/usr/share/fonts/TTF/"
+
+ # install fontconfig files
+ install -Dm0644 ../30-0-liberation-sans-narrow.conf "$pkgdir/etc/fonts/conf.avail/30-$pkgname-sans.conf"
+
+ # install license
+ install -Dm644 "${srcdir}/liberation-fonts-ttf-${pkgver}/License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7d26d0c2aafa
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+