summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRex2020-06-30 10:20:01 +0800
committerRex2020-06-30 10:20:01 +0800
commit162045e2a5eb67f4b0f58137a5d04218d0882062 (patch)
treec73600ca2295b0cfe6277074801647ecaea517e8
downloadaur-162045e2a5eb67f4b0f58137a5d04218d0882062.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1653499d065f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-ligatured-hack
+ pkgdesc = Latest ligatures with Hack font built with fully automated CI/CD by gaplo917
+ pkgver = v3.003+FC3.1+JBMv1.0.6
+ pkgrel = 1
+ url = https://github.com/gaplo917/Ligatured-Hack
+ arch = any
+ license = GPL3
+ depends = fontconfig
+ provides = ttf-hack
+ conflicts = ttf-hack-ligatured
+ source = https://github.com/gaplo917/Ligatured-Hack/releases/download/v3.003+FC3.1+JBMv1.0.6/HackLigatured-v3.003+FC3.1+JBMv1.0.6.zip
+ source = v3.003+FC3.1+JBMv1.0.6-LICENSE::https://raw.githubusercontent.com/gaplo917/Ligatured-Hack/master/LICENSE
+ sha256sums = 1e694ffdde1d2039492a1472bf65c95c72c29b1852b8fe96c2620e59eebb998f
+ sha256sums = 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903
+
+pkgname = ttf-ligatured-hack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c143a3b28c88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: timescam <rex.ky.ng at gmail dot com>
+
+pkgname=ttf-ligatured-hack
+_pkgname=hack-ligatured
+pkgver=v3.003+FC3.1+JBMv1.0.6
+pkgrel=1
+pkgdesc="Latest ligatures with Hack font built with fully automated CI/CD by gaplo917"
+arch=("any")
+url="https://github.com/gaplo917/Ligatured-Hack"
+license=("GPL3")
+depends=("fontconfig")
+provides=("ttf-hack")
+conflicts=("ttf-hack-ligatured")
+source=("https://github.com/gaplo917/Ligatured-Hack/releases/download/${pkgver}/HackLigatured-${pkgver}.zip"
+ "${pkgver}-LICENSE::https://raw.githubusercontent.com/gaplo917/Ligatured-Hack/master/LICENSE")
+sha256sums=("1e694ffdde1d2039492a1472bf65c95c72c29b1852b8fe96c2620e59eebb998f"
+ "8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903")
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/fonts/TTF/${_pkgname}
+ install -m644 ${srcdir}/*.ttf ${pkgdir}/usr/share/fonts/TTF/${_pkgname}
+ install -Dm644 ./${pkgver}-LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/${pkgver}-LICENSE
+}
+