summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpiros Georgaras2015-08-12 14:35:02 +0300
committerSpiros Georgaras2015-08-12 14:35:02 +0300
commiteb1b8383f92d3ff1e968a8acabb2327eebe6af22 (patch)
tree1717a2e0165a84cc7d0b8316e6358094a7e2e969
downloadaur-eb1b8383f92d3ff1e968a8acabb2327eebe6af22.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--ttf-linex-fonts.install14
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a0b7529a0fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-linex-fonts
+ pkgdesc = Fonts suitable for education and institutional use
+ pkgver = 2.2.7
+ pkgrel = 1
+ url = http://gata.linex.org/trac/browser/fonts-linex/
+ install = ttf-linex-fonts.install
+ arch = any
+ license = GPL2
+ depends = fontconfig
+ depends = xorg-font-utils
+ depends = sed
+ depends = binutils
+ source = http://httpredir.debian.org/debian/pool/main/f/fonts-linex/fonts-linex_2.2-7_all.deb
+ md5sums = d1bf208d3df1efe26718357863c0a016
+
+pkgname = ttf-linex-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d10dbb85e12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Spiros Georgaras <sng@hellug.gr>
+pkgname=ttf-linex-fonts
+pkgver=2.2.7
+pkgrel=1
+pkgdesc="Fonts suitable for education and institutional use"
+arch=('any')
+license=('GPL2')
+url="http://gata.linex.org/trac/browser/fonts-linex/"
+depends=('fontconfig' 'xorg-font-utils' 'sed' 'binutils')
+source=('http://httpredir.debian.org/debian/pool/main/f/fonts-linex/fonts-linex_2.2-7_all.deb')
+md5sums=('d1bf208d3df1efe26718357863c0a016')
+install=${pkgname}.install
+
+build(){
+cd "${srcdir}"
+ar xv fonts-linex_2.2-7_all.deb
+tar xJf data.tar.xz
+sed -i -e 's/Debian GNU.Linux/Arch/' -e 's/GPL-2/GPL2/' ${srcdir}/usr/share/doc/fonts-linex/copyright
+}
+
+package() {
+install -d ${pkgdir}/usr/share/fonts/TTF
+install -Dm644 ${srcdir}/usr/share/fonts/truetype/linex/*.ttf ${pkgdir}/usr/share/fonts/TTF/
+install -d ${pkgdir}/usr/share/licenses/${pkgname}
+install -Dm644 ${srcdir}/usr/share/doc/fonts-linex/copyright ${pkgdir}/usr/share/licenses/${pkgname}/copyright
+}
diff --git a/ttf-linex-fonts.install b/ttf-linex-fonts.install
new file mode 100644
index 000000000000..330d7ed411f4
--- /dev/null
+++ b/ttf-linex-fonts.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -vf > /dev/null
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+