summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorR Daneel2015-07-23 22:27:57 +0800
committerR Daneel2015-07-23 22:27:57 +0800
commite3e7a01509dc4668fc983af7c3538ee182607956 (patch)
treee42430aaf183dd96e8efff74c9100a82f052f917
downloadaur-e3e7a01509dc4668fc983af7c3538ee182607956.tar.gz
Initial import from AUR
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD25
-rwxr-xr-xttf-malayalam-fonts.install15
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..973c1d985f72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-malayalam-font-chilanka
+ pkgdesc = This is Chilanka, a font belonging to a set of TrueType and OpenType fonts released under the GNU General Public License for Malayalam Language.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://smc.org.in/fonts/
+ install = ttf-malayalam-fonts.install
+ arch = any
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://smc.org.in/downloads/fonts/chilanka/Chilanka.ttf
+ source = https://gitlab.com/smc/chilanka/raw/master/67-smc-chilanka.conf
+ md5sums = fafb5ca61bb936ce09cc0a4124578326
+ md5sums = f626730347f96e8f323e2bbd3df1a768
+
+pkgname = ttf-malayalam-font-chilanka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2a7e3dc9f9e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Aashik S aashiks at gmail dot com
+# Maintainer: http://smc.org.in
+# Contributor: Akshay S Dinesh asdofindia at gmail dot com
+
+pkgname=ttf-malayalam-font-chilanka
+pkgver=1.0
+pkgrel=1
+pkgdesc="This is Chilanka, a font belonging to a set of TrueType and OpenType fonts released under the
+GNU General Public License for Malayalam Language."
+arch=(any)
+url="http://smc.org.in/fonts/"
+depends=(fontconfig xorg-font-utils)
+source=("http://smc.org.in/downloads/fonts/chilanka/Chilanka.ttf"
+ "https://gitlab.com/smc/chilanka/raw/master/67-smc-chilanka.conf")
+md5sums=('fafb5ca61bb936ce09cc0a4124578326'
+ 'f626730347f96e8f323e2bbd3df1a768')
+install=ttf-malayalam-fonts.install
+
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/fonts/TTF" || return 1
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/TTF"
+ mkdir -p "${pkgdir}/etc/fonts/conf.d" || return 1
+ install *.conf "${pkgdir}/etc/fonts/conf.d" || return 1
+}
diff --git a/ttf-malayalam-fonts.install b/ttf-malayalam-fonts.install
new file mode 100755
index 000000000000..26e912fe9c2c
--- /dev/null
+++ b/ttf-malayalam-fonts.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "Running fc-cache to update font cache"
+ fc-cache -fs
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+ echo "Finished updating font cache"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}