summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorR Daneel2015-07-23 22:29:33 +0800
committerR Daneel2015-07-23 22:29:33 +0800
commit05ed37ece388fd80b05d89fd0711f3264eb9a323 (patch)
tree2e09eac30cbd1d2a8e5ea233a04e4d896b10475e
downloadaur-05ed37ece388fd80b05d89fd0711f3264eb9a323.tar.gz
Initial import from AUR
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD25
-rwxr-xr-xttf-malayalam-fonts.install15
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d08c30be650
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-malayalam-font-dyuthi
+ pkgdesc = This is Dyuthi, a font belonging to a set of TrueType and OpenType fonts released under the GNU General Public License for Malayalam Language.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://smc.org.in/fonts/
+ install = ttf-malayalam-fonts.install
+ arch = any
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://smc.org.in/downloads/fonts/dyuthi/Dyuthi.ttf
+ source = https://gitlab.com/smc/dyuthi/raw/master/67-smc-dyuthi.conf
+ md5sums = af094c3f037c079b837efbe6224cd8f8
+ md5sums = f4a275e1e8a1bd33c90ed44f1ee84017
+
+pkgname = ttf-malayalam-font-dyuthi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cdbd834c5c8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Aashik S aashiks at gmail dot com
+# Maintainer: http://smc.org.in
+# Contributor: Akshay S Dinesh asdofindia at gmail dot com
+
+pkgname=ttf-malayalam-font-dyuthi
+pkgver=1.0
+pkgrel=1
+pkgdesc="This is Dyuthi, a font belonging to a set of TrueType and OpenType fonts released under the
+GNU General Public License for Malayalam Language."
+arch=(any)
+url="http://smc.org.in/fonts/"
+depends=(fontconfig xorg-font-utils)
+source=("http://smc.org.in/downloads/fonts/dyuthi/Dyuthi.ttf"
+ "https://gitlab.com/smc/dyuthi/raw/master/67-smc-dyuthi.conf")
+md5sums=('af094c3f037c079b837efbe6224cd8f8'
+ 'f4a275e1e8a1bd33c90ed44f1ee84017')
+install=ttf-malayalam-fonts.install
+
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/fonts/TTF" || return 1
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/TTF"
+ mkdir -p "${pkgdir}/etc/fonts/conf.d" || return 1
+ install *.conf "${pkgdir}/etc/fonts/conf.d" || return 1
+}
diff --git a/ttf-malayalam-fonts.install b/ttf-malayalam-fonts.install
new file mode 100755
index 000000000000..26e912fe9c2c
--- /dev/null
+++ b/ttf-malayalam-fonts.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "Running fc-cache to update font cache"
+ fc-cache -fs
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+ echo "Finished updating font cache"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}