summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrski2015-06-08 17:52:43 +0100
committerrski2015-06-08 17:52:43 +0100
commit48fbe9a9a7ef89b5bc2f0ace5f8310b60087e784 (patch)
tree3ad752841f81768e9eebe6f0cc7dde159dd74435
downloadaur-48fbe9a9a7ef89b5bc2f0ace5f8310b60087e784.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--ttf.install15
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd87c23b7f59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-manaspace
+ pkgdesc = Secret of Mana Font converted to TTF
+ pkgver = 1
+ pkgrel = 2
+ url = http://www.zone38.net/font/
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.zone38.net/font/manaspc_ger.zip
+ md5sums = f9f00e48dce0cf5a8fae97654d8a0419
+
+pkgname = ttf-manaspace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea0f8bc3da44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Romanos 'rski' Skiadas <rom skiad at gmail dot com>
+# Contributor: demonicmaniac < namida1@gmx.net >
+
+pkgname=ttf-manaspace
+pkgver=1
+pkgrel=2
+pkgdesc="Secret of Mana Font converted to TTF"
+arch=('any')
+url="http://www.zone38.net/font/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://www.zone38.net/font/manaspc_ger.zip)
+md5sums=('f9f00e48dce0cf5a8fae97654d8a0419')
+
+package() {
+ cd ${srcdir}
+
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install *.ttf ${pkgdir}/usr/share/fonts/TTF
+
+}
+
+
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..16db3c130c72
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f -s >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}