summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Johannesen2020-08-30 11:46:40 -0400
committerJack Johannesen2020-08-30 11:53:26 -0400
commit287f5a6a481698d096f41605bc0e7f7cee61a722 (patch)
tree842b0413a3e5521c23bb12ac89f094e33ec619fc
downloadaur-287f5a6a481698d096f41605bc0e7f7cee61a722.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cb8995cc05e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-material-design-icons-extended
+ pkgdesc = An extended Material Design icons font by the guys over at materialdesignicons.com
+ pkgver = 5.4.55
+ pkgrel = 1
+ url = https://materialdesignicons.com/
+ arch = any
+ license = custom:SIL
+ provides = ttf-material-design-icons-extended
+ noextract = materialdesignicons-webfont.ttf
+ noextract = LICENSE
+ source = https://cdn.materialdesignicons.com/5.4.55/fonts/materialdesignicons-webfont.ttf
+ source = https://raw.githubusercontent.com/Templarian/MaterialDesign/master/LICENSE
+ md5sums = 8ed8f0719def123d77bf6ea8919b8d8a
+ md5sums = 1ac896da581480f567e06aa54c92b033
+
+pkgname = ttf-material-design-icons-extended
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13a0f0c5becb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+# Maintainer: Jack Johannesen <jack AT insertdomain DOT name>
+
+pkgname=ttf-material-design-icons-extended
+pkgver=5.4.55
+pkgrel=1
+pkgdesc="An extended Material Design icons font by the guys over at materialdesignicons.com"
+arch=('any')
+url="https://materialdesignicons.com/"
+license=('custom:SIL')
+depends=()
+makedepends=()
+provides=('ttf-material-design-icons-extended')
+conflicts=()
+source=('https://cdn.materialdesignicons.com/5.4.55/fonts/materialdesignicons-webfont.ttf' 'https://raw.githubusercontent.com/Templarian/MaterialDesign/master/LICENSE')
+noextract=('materialdesignicons-webfont.ttf' 'LICENSE')
+md5sums=('8ed8f0719def123d77bf6ea8919b8d8a'
+ '1ac896da581480f567e06aa54c92b033')
+
+build() {
+ # Rename the ttf file to something more sensible for installation.
+ rename \
+ $srcdir/materialdesignicons-webfont.ttf \
+ $srcdir/material-design-icons-extended.ttf \
+ $srcdir/materialdesignicons-webfont.ttf
+}
+
+package() {
+ # Install the LICENSE.
+ install \
+ -Dm644 \
+ $srcdir/LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE";
+ # Install the ttf file.
+ install \
+ -Dm644 \
+ $srcdir/material-design-icons-extended.ttf \
+ "$pkgdir/usr/share/fonts/TTF/material-design-icons-extended.ttf";
+}