summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Merry2015-06-14 19:25:31 +0100
committerAlex Merry2015-06-14 19:25:31 +0100
commit89294105916eaa11465651effdbacedb398d3c5d (patch)
treeb1deb048c5d49ad2df87accbd003ff0522a9d17d
downloadaur-89294105916eaa11465651effdbacedb398d3c5d.tar.gz
Import from AUR 3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--license.txt36
-rw-r--r--ttf.install20
4 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b2e8b20fd29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ttf-mathtype
+ pkgdesc = Fonts supplied with MathType
+ pkgver = 6.9
+ pkgrel = 1
+ url = http://www.dessci.com/en/dl/fonts/
+ install = ttf.install
+ arch = any
+ license = custom
+ makedepends = cabextract
+ depends = fontconfig
+ depends = xorg-font-utils
+ noextract = DS_Fonts_6.9_(TT).exe
+ noextract = DS_Fonts_6.9_(PS).exe
+ source = http://www.dessci.com/en/dl/DS_Fonts_6.9_(TT).exe
+ source = http://www.dessci.com/en/dl/DS_Fonts_6.9_(PS).exe
+ source = license.txt
+ md5sums = cfd1577b68103fd8479a2561aa3f7d0c
+ md5sums = 26b94334992529dd9000b3c491245526
+ md5sums = 662f7c87498d513571148913ae09313b
+
+pkgname = ttf-mathtype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca51dcb1ceb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+
+pkgname=ttf-mathtype
+pkgver=6.9
+pkgrel=1
+pkgdesc="Fonts supplied with MathType"
+url="http://www.dessci.com/en/dl/fonts/"
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('cabextract')
+arch=('any')
+license=('custom')
+install=ttf.install
+source=("http://www.dessci.com/en/dl/DS_Fonts_${pkgver}_(TT).exe"
+ "http://www.dessci.com/en/dl/DS_Fonts_${pkgver}_(PS).exe"
+ 'license.txt')
+noextract=("DS_Fonts_${pkgver}_(TT).exe"
+ "DS_Fonts_${pkgver}_(PS).exe")
+md5sums=('cfd1577b68103fd8479a2561aa3f7d0c'
+ '26b94334992529dd9000b3c491245526'
+ '662f7c87498d513571148913ae09313b')
+
+prepare() {
+ mkdir -p "${srcdir}/fonts/ttf"
+ cd "${srcdir}/fonts/ttf"
+ cabextract "${srcdir}/DS_Fonts_${pkgver}_(TT).exe"
+
+ mkdir -p "${srcdir}/fonts/ps"
+ cd "${srcdir}/fonts/ps"
+ cabextract "${srcdir}/DS_Fonts_${pkgver}_(PS).exe"
+}
+
+package() {
+ # Install TrueType fonts
+ cd "${srcdir}/fonts/ttf"
+ install -d -m755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/TTF/"
+
+ # Install Type1 fonts
+ cd "${srcdir}/fonts/ps"
+ install -d -m755 "${pkgdir}/usr/share/fonts/Type1"
+ install -m644 *.afm *.pfb *.pfm "${pkgdir}/usr/share/fonts/Type1/"
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..b449db43d390
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,36 @@
+MathType Font License Agreement
+
+
+License Grant
+
+This Font Installer and the Fonts it installs ("Software") are products
+of Design Science, Inc., and protected under U.S. and international
+copyright law. By continuing this installation process, you are
+agreeing to abide by the restrictions described in this agreement.
+
+Design Science grants you a non-exclusive license to use the Software.
+You are permitted to make copies of the Fonts to install into printers.
+You may distribute unlimited copies of the Software to third parties,
+including copies for commercial distribution, as long as each copy is
+unmodified from the original. Such third parties are required to abide
+by this license agreement.
+
+You may not reverse assemble, reverse compile, or otherwise translate
+the Software. You may not modify the Software or create derived works
+from the Software. You are not permitted to distribute the Software with
+any implementation of the TeX typesetting system as defined by The TeX
+Book, by Donald Knuth. This restriction does not apply to software
+products that convert the TeX language to or from other languages or
+word processing document file formats.
+
+
+
+Limited Warranty
+
+Design Science makes no warranties, including warranties of
+merchantability and fitness for a particular purpose. There are no
+remedies under this warranty. Design Science is not responsible for any
+damages incurring from the use of the Software. Some states do not allow
+limitations on implied warranties, so some of the above limitations may
+not apply to you.
+
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..be90084ca50b
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*