summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2015-08-08 11:59:03 -0400
committerpzl2015-08-08 11:59:03 -0400
commite2afdb31ec6bf6e2f36f817a711016f39c352d6a (patch)
tree5641d15abaa3ca0a0c243391c60ea41c1c1ac141
downloadaur-e2afdb31ec6bf6e2f36f817a711016f39c352d6a.tar.gz
move package into aur4/git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--ttf-meslo.install17
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5cad151fc22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-meslo
+ pkgdesc = Meslo LG is a customized version of Apple's Menlo font (includes DZ version)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://github.com/andreberg/Meslo-Font
+ install = ttf-meslo.install
+ arch = any
+ license = Apache
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = Meslo-1.2.1.zip::https://github.com/andreberg/Meslo-Font/blob/master/dist/v1.2.1/Meslo%20LG%20v1.2.1.zip?raw=true
+ source = Meslo-1.2.1-DZ.zip::https://github.com/andreberg/Meslo-Font/blob/master/dist/v1.2.1/Meslo%20LG%20DZ%20v1.2.1.zip?raw=true
+ sha256sums = d0bcb7668dda8fa1a0f8162d626adb434c32854e243b5bd52a717cf569af08d0
+ sha256sums = e5201a6816281872c23a2b2f43ac91dc8c1f9d91e9f4b82d64e9bfcb769ecb52
+
+pkgname = ttf-meslo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ea1a93902a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: pzl <alsoelp@gmail.com>
+# Contributor: Pablo Olmos de Aguilera C. <pablo at glatelier dot org>
+# Contributor: David Goodlad <david at goodlad dot ca>
+# Contributor: William Sheldon <tang0th at gmx dot com>
+
+pkgname=ttf-meslo
+_pkgname=Meslo
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Meslo LG is a customized version of Apple's Menlo font (includes DZ version)"
+arch=('any')
+url="http://github.com/andreberg/Meslo-Font"
+license=('Apache')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf-meslo.install
+source=(
+$_pkgname-${pkgver}.zip::https://github.com/andreberg/Meslo-Font/blob/master/dist/v${pkgver}/Meslo%20LG%20v${pkgver}.zip?raw=true
+$_pkgname-${pkgver}-DZ.zip::https://github.com/andreberg/Meslo-Font/blob/master/dist/v${pkgver}/Meslo%20LG%20DZ%20v${pkgver}.zip?raw=true
+)
+sha256sums=('d0bcb7668dda8fa1a0f8162d626adb434c32854e243b5bd52a717cf569af08d0'
+ 'e5201a6816281872c23a2b2f43ac91dc8c1f9d91e9f4b82d64e9bfcb769ecb52')
+
+package()
+{
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 $srcdir/Meslo\ LG\ v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF/
+ install -m644 $srcdir/Meslo\ LG\ DZ\ v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF/
+}
diff --git a/ttf-meslo.install b/ttf-meslo.install
new file mode 100644
index 000000000000..2dc1d4132ca5
--- /dev/null
+++ b/ttf-meslo.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: