summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 12:12:43 +0200
committerMartin Doege2015-06-09 12:12:43 +0200
commit754e94c241e6b8285ab689987fbe1345a258946a (patch)
tree6063c71ab54da445db635659a5850b7c32f7f5ee
downloadaur-754e94c241e6b8285ab689987fbe1345a258946a.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--license.txt13
-rw-r--r--ttf.install17
5 files changed, 89 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..39af87834974
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-mgopen
+ pkgdesc = TrueType fonts containing glyphs for the Latin and Greek alphabet
+ pkgver = 1.1
+ pkgrel = 10
+ url = http://www.zvr.gr/typo/mgopen/index
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://ftp.debian.org/debian/pool/main/t/ttf-mgopen/ttf-mgopen_1.1.orig.tar.gz
+ source = license.txt
+
+pkgname = ttf-mgopen
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f66f13bb48d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-mgopen
+ pkgdesc = TrueType fonts containing glyphs for the Latin and Greek alphabet
+ pkgver = 1.1
+ pkgrel = 10
+ url = http://www.zvr.gr/typo/mgopen/index
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://ftp.debian.org/debian/pool/main/t/ttf-mgopen/ttf-mgopen_1.1.orig.tar.gz
+ source = license.txt
+ sha256sums = 14a9c967b8e84c95da2e27098b45ec8f1b64a160948b091a3c6220f05186d15a
+ sha256sums = 2e2cbbc817d6b3e48b6aabd8d88fa800418cefe5b523d5429ce4f29480a4cad9
+
+pkgname = ttf-mgopen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d58daa4310c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: TDY <tdy@archlinux.info>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Robert Emil Berge <filoktetes@linuxophic.org>
+
+pkgname=ttf-mgopen
+pkgver=1.1
+pkgrel=10
+pkgdesc="TrueType fonts containing glyphs for the Latin and Greek alphabet"
+arch=('any')
+url="http://www.zvr.gr/typo/mgopen/index"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+#source=(http://pub.ellak.gr/fonts/mgopen/files/MgOpen.tar.gz
+source=(http://ftp.debian.org/debian/pool/main/t/$pkgname/${pkgname}_$pkgver.orig.tar.gz
+ license.txt)
+sha256sums=('14a9c967b8e84c95da2e27098b45ec8f1b64a160948b091a3c6220f05186d15a'
+ '2e2cbbc817d6b3e48b6aabd8d88fa800418cefe5b523d5429ce4f29480a4cad9')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver.orig/TTFs"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 MgOpen*.ttf "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..36482331d152
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,13 @@
+Copyright © 2004 by MAGENTA Ltd. All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of the fonts accompanying this license ("Fonts") and associated documentation files (the "Font Software"), to reproduce and distribute the Font Software, including without limitation the rights to use, copy, merge, publish, distribute, and/or sell copies of the Font Software, and to permit persons to whom the Font Software is furnished to do so, subject to the following conditions:
+
+The above copyright and this permission notice shall be included in all copies of one or more of the Font Software typefaces.
+
+The Font Software may be modified, altered, or added to, and in particular the designs of glyphs or characters in the Fonts may be modified and additional glyphs or characters may be added to the Fonts, only if the fonts are renamed to names not containing the word "MgOpen", or if the modifications are accepted for inclusion in the Font Software itself by the each appointed Administrator.
+
+This License becomes null and void to the extent applicable to Fonts or Font Software that has been modified and is distributed under the "MgOpen" name.
+
+The Font Software may be sold as part of a larger software package but no copy of one or more of the Font Software typefaces may be sold by itself.
+
+THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF COPYRIGHT, PATENT, TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL MAGENTA OR PERSONS OR BODIES IN CHARGE OF ADMINISTRATION AND MAINTENANCE OF THE FONT SOFTWARE BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, INCLUDING ANY GENERAL, SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF THE USE OR INABILITY TO USE THE FONT SOFTWARE OR FROM OTHER DEALINGS IN THE FONT SOFTWARE.
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7370041e234b
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: