summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2015-06-14 01:57:31 +0900
committerorumin2015-06-14 01:57:31 +0900
commit2932ff4087e39f3df7d3358d5d7dca9d4c731abe (patch)
tree7f1c57266cb6bd62c21c341b8aeaa9bef91cc0a5
downloadaur-2932ff4087e39f3df7d3358d5d7dca9d4c731abe.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--ttf.install15
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3293f0c533a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-mikachan
+ pkgdesc = Mikachan Japanese TrueType fonts for X.
+ pkgver = 8.9
+ pkgrel = 1
+ url = http://mikachan-font.com/
+ install = ttf.install
+ arch = any
+ license = CUSTOM
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://jaist.dl.sourceforge.jp/mikachan/5513/mikachanfont-8.9.tar.bz2
+ md5sums = 8ac2b94336e76fa80996d0be70c557de
+
+pkgname = ttf-mikachan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ffad84e3b2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: orumin <dev@orum.in>
+
+pkgname=ttf-mikachan
+pkgver=8.9
+pkgrel=1
+pkgdesc="Mikachan Japanese TrueType fonts for X."
+arch=('any')
+url="http://mikachan-font.com/"
+license=('CUSTOM')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+_mirror="jaist"
+source=(http://${_mirror}.dl.sourceforge.jp/mikachan/5513/mikachanfont-${pkgver}.tar.bz2)
+md5sums=('8ac2b94336e76fa80996d0be70c557de')
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 "mikachanfont-${pkgver}"/fonts/*.ttf "${pkgdir}/usr/share/fonts/TTF"
+
+ install -d "${pkgdir}/usr/share/licenses/custom/${pkgname}"
+ install -m644 "mikachanfont-${pkgver}"/COPYRIGHT "${pkgdir}/usr/share/licenses/custom/${pkgname}/license.txt"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..4d5d74ff35a4
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}