summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkiwiyou2020-04-06 12:01:34 +0900
committerkiwiyou2020-04-06 12:01:34 +0900
commit691d41a2f5d3de0347b571b2a9f1926cbcbc03e1 (patch)
tree3978d8d0aed999b94509af695453fb14b4c88e4a
downloadaur-ttf-misaki.tar.gz
Create package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6a3f9e6ce8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ttf-misaki
+ pkgdesc = Truetype Japanese 8x8 font supporting Gothic and Mincho.
+ pkgver = 2019_10_19
+ pkgrel = 1
+ url = https://littlelimit.net/misaki.htm
+ arch = any
+ license = custom
+ source = https://littlelimit.net/arc/misaki/misaki_ttf_2019-10-19.zip
+ sha256sums = a3bb61d161f1fd1bd09ea57e3a923ca54397a469d2ccba7be3119688c5024e88
+
+pkgname = ttf-misaki
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2aef44359c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: kiwiyou <kiwiyou.dev@gmail.com>
+
+pkgname=ttf-misaki
+pkgver=2019_10_19
+pkgrel=1
+pkgdesc='Truetype Japanese 8x8 font supporting Gothic and Mincho.'
+arch=(any)
+url='https://littlelimit.net/misaki.htm'
+source=("https://littlelimit.net/arc/misaki/misaki_ttf_${pkgver//_/-}.zip")
+sha256sums=("a3bb61d161f1fd1bd09ea57e3a923ca54397a469d2ccba7be3119688c5024e88")
+license=('custom')
+
+build() {
+ sed -n "/These fonts/,/Copyright/p" misaki.txt > LICENSE
+}
+
+package() {
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF" "misaki_gothic.ttf"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF" "misaki_gothic_2nd.ttf"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF" "misaki_mincho.ttf"
+
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" "readme.txt"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" "misaki.txt"
+
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "LICENSE"
+}