summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-06-29 20:40:25 +0200
committerAdrian Perez de Castro2015-06-29 20:40:25 +0200
commit664dcc4f03485e1bddc31d168ecf3f3187ab3e6f (patch)
treedf8610ad3fa35a2304723135f61f3451b4fedf4f
parent54bbc9df3142992ca2788526ba4d8445cab7a2cb (diff)
downloadaur-664dcc4f03485e1bddc31d168ecf3f3187ab3e6f.tar.gz
Update build script location, build Bold/Retina variants
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2f88617125a..3e2d0d53e14d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-monoid-git
pkgdesc = Open Source coding font
- pkgver = r200.39641b8
+ pkgver = r240.2da34c4
pkgrel = 1
url = http://larsenwork.github.io/monoid/
install = ttf-monoid-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 20a2f7d1a493..75ccee1b090c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgname='ttf-monoid-git'
pkgdesc='Open Source coding font'
-pkgver=r200.39641b8
+pkgver=r240.2da34c4
pkgrel=1
arch=('any')
license=('custom:MIT')
@@ -22,22 +22,23 @@ pkgver () {
}
prepare () {
- cd "${pkgname}"
+ cd "${pkgname}/Scripts"
patch -p1 < "${srcdir}/fontbuilder-python3.patch"
}
build () {
cd "${pkgname}"
- python3 -c 'import fontbuilder; fontbuilder.build("_regular", "Source", "Monoid.sfdir");'
- python3 -c 'import fontbuilder; fontbuilder.build("_oblique", "Source", "Monoid-Oblique.sfdir");'
+ export PYTHONPATH="$(pwd)/Scripts"
+ python3 -c 'import fontbuilder; fontbuilder.build("_build", "Source/Monoid.sfdir");'
+ python3 -c 'import fontbuilder; fontbuilder.build("_build", "Source/Monoid-Bold.sfdir");'
+ python3 -c 'import fontbuilder; fontbuilder.build("_build", "Source/Monoid-Oblique.sfdir");'
+ python3 -c 'import fontbuilder; fontbuilder.build("_build", "Source/Monoid-Retina.sfdir");'
}
package () {
cd "${pkgname}"
- install -Dm644 _regular/Monoid.ttf \
- "${pkgdir}/usr/share/fonts/TTF/Monoid.ttf"
- install -Dm644 _oblique/Monoid.ttf \
- "${pkgdir}/usr/share/fonts/TTF/Monoid-Oblique.ttf"
+ install -m755 -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 -t "${pkgdir}/usr/share/fonts/TTF" _build/*.ttf
install -Dm644 Readme.md \
"${pkgdir}/usr/share/licenses/${pkgname}/README.md"
}