summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:39:13 +0200
committerSanskritFritz2015-06-14 00:39:13 +0200
commit180dfa7e19aeecc41036554a8d93b0cf844d1c34 (patch)
treea2cc4eb498db404ae65dbc5619eb15be976e2d49
downloadaur-180dfa7e19aeecc41036554a8d93b0cf844d1c34.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--ttf.install20
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1102d5761393
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-montepetrum
+ pkgdesc = A very tall, narrow, thin, sans serif font.
+ pkgver = 1
+ pkgrel = 3
+ url = http://aajohan.deviantart.com/art/Montepetrum-Font-151870278
+ install = ttf.install
+ arch = any
+ license = CCPL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://fc01.deviantart.net/fs70/f/2010/027/f/5/Montepetrum___Font_by_aajohan.zip
+ md5sums = d631b527bec723d6fbd4324943672b13
+
+pkgname = ttf-montepetrum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbcd2baeb0ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: SanskritFritz (gmail)
+# Contributor: David Spicer <azleifel at googlemail dot com>
+
+pkgname=ttf-montepetrum
+pkgver=1
+pkgrel=3
+pkgdesc="A very tall, narrow, thin, sans serif font."
+arch=('any')
+url="http://aajohan.deviantart.com/art/Montepetrum-Font-151870278"
+license=('CCPL')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=("http://fc01.deviantart.net/fs70/f/2010/027/f/5/Montepetrum___Font_by_aajohan.zip")
+md5sums=('d631b527bec723d6fbd4324943672b13')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF"
+
+ cd "${srcdir}/Montepetrum"
+ install -m 644 *.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -Dm 644 "Please read me.txt" "${pkgdir}/usr/share/doc/$pkgname/README"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..4f5212ef22ba
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*