summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbirdflesh2015-06-09 19:50:09 +0300
committerbirdflesh2015-06-09 19:50:09 +0300
commit7fa7ea58251605918212d8dd9a14fb4d3268c397 (patch)
treef122f282d42e21efce04c9852e714816d4719f6b
downloadaur-7fa7ea58251605918212d8dd9a14fb4d3268c397.tar.gz
Initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD42
-rw-r--r--ttf-ms-fonts.install16
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45a1bd715c1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = ttf-ms-fonts
+ pkgdesc = Core TTF Fonts from Microsoft
+ pkgver = 2.0
+ pkgrel = 10
+ url = http://corefonts.sourceforge.net/
+ install = ttf-ms-fonts.install
+ arch = any
+ license = custom:microsoft
+ makedepends = libarchive>=3.0.2
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ provides = ttf-font
+ source = http://downloads.sourceforge.net/corefonts/andale32.exe
+ source = http://downloads.sourceforge.net/corefonts/arial32.exe
+ source = http://downloads.sourceforge.net/corefonts/arialb32.exe
+ source = http://downloads.sourceforge.net/corefonts/comic32.exe
+ source = http://downloads.sourceforge.net/corefonts/courie32.exe
+ source = http://downloads.sourceforge.net/corefonts/georgi32.exe
+ source = http://downloads.sourceforge.net/corefonts/impact32.exe
+ source = http://downloads.sourceforge.net/corefonts/times32.exe
+ source = http://downloads.sourceforge.net/corefonts/trebuc32.exe
+ source = http://downloads.sourceforge.net/corefonts/verdan32.exe
+ source = http://downloads.sourceforge.net/corefonts/webdin32.exe
+ md5sums = cbdc2fdd7d2ed0832795e86a8b9ee19a
+ md5sums = 9637df0e91703179f0723ec095a36cb5
+ md5sums = c9089ae0c3b3d0d8c4b0a95979bb9ff0
+ md5sums = 2b30de40bb5e803a0452c7715fc835d1
+ md5sums = 4e412c772294403ab62fb2d247d85c60
+ md5sums = 4d90016026e2da447593b41a8d8fa8bd
+ md5sums = 7907c7dd6684e9bade91cff82683d9d7
+ md5sums = ed39c8ef91b9fb80f76f702568291bd5
+ md5sums = 0d7ea16cac6261f8513a061fbfcdb2b5
+ md5sums = 12d2a75f8156e10607be1eaa8e8ef120
+ md5sums = 230a1d13a365b22815f502eb24d9149b
+
+pkgname = ttf-ms-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..066bd8c24557
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: birdflesh <antkoul at gmail dot com>
+# Contributor: Army <uli.armbruster@gmail.com>
+# Contributor: Thayer Williams <thayer@archlinux.org>
+# Contributor: dale <dale@archlinux.org>
+
+pkgname=ttf-ms-fonts
+pkgver=2.0
+pkgrel=10
+pkgdesc="Core TTF Fonts from Microsoft"
+arch=('any')
+url="http://corefonts.sourceforge.net/"
+license=('custom:microsoft')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('libarchive>=3.0.2')
+provides=('ttf-font')
+install=$pkgname.install
+_sfpath="http://downloads.sourceforge.net/corefonts"
+source=($_sfpath/andale32.exe $_sfpath/arial32.exe $_sfpath/arialb32.exe
+ $_sfpath/comic32.exe $_sfpath/courie32.exe $_sfpath/georgi32.exe
+ $_sfpath/impact32.exe $_sfpath/times32.exe $_sfpath/trebuc32.exe
+ $_sfpath/verdan32.exe $_sfpath/webdin32.exe)
+md5sums=('cbdc2fdd7d2ed0832795e86a8b9ee19a'
+ '9637df0e91703179f0723ec095a36cb5'
+ 'c9089ae0c3b3d0d8c4b0a95979bb9ff0'
+ '2b30de40bb5e803a0452c7715fc835d1'
+ '4e412c772294403ab62fb2d247d85c60'
+ '4d90016026e2da447593b41a8d8fa8bd'
+ '7907c7dd6684e9bade91cff82683d9d7'
+ 'ed39c8ef91b9fb80f76f702568291bd5'
+ '0d7ea16cac6261f8513a061fbfcdb2b5'
+ '12d2a75f8156e10607be1eaa8e8ef120'
+ '230a1d13a365b22815f502eb24d9149b')
+
+package() {
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+
+ for font in *.{ttf,TTF}; do
+ install -m644 $font "$pkgdir/usr/share/fonts/TTF/$(echo $font|tr A-Z a-z)"
+ done
+
+ install -Dm644 Licen.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/ttf-ms-fonts.install b/ttf-ms-fonts.install
new file mode 100644
index 000000000000..7d26d0c2aafa
--- /dev/null
+++ b/ttf-ms-fonts.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+