summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSuphal2020-08-06 18:24:46 +0545
committerSuphal2020-08-06 18:24:46 +0545
commit760a57873fad79346ff2b6f0dfd4ded93d10fa0f (patch)
tree89691218b13b4b21dc1b2c4bdde0fb84e5e9e0cc
downloadaur-760a57873fad79346ff2b6f0dfd4ded93d10fa0f.tar.gz
A collection of popular Nepali fonts
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..337882784624
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-nepali-font-git
+ pkgdesc = Collection Of Pupular Nepali Fonts
+ pkgver = r6.e645fa5
+ pkgrel = 1
+ url = git+https://github.com/SuphalBhattarai/nepali-fonts
+ arch = x86_64
+ arch = i686
+ makedepends = git
+ depends = fontconfig
+ provides = ttf-nepali-font-git
+ source = git+https://github.com/SuphalBhattarai/nepali-fonts
+ md5sums = SKIP
+
+pkgname = ttf-nepali-font-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1332f51c94dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Suphal Bhattarai suphalbhattarai4@gmail.com
+pkgname=ttf-nepali-font-git
+pkgver=r6.e645fa5
+pkgrel=1
+pkgdesc="Collection Of Pupular Nepali Fonts"
+arch=(x86_64 i686)
+url="git+https://github.com/SuphalBhattarai/nepali-fonts"
+depends=(fontconfig)
+makedepends=(git )
+provides=(ttf-nepali-font-git)
+source=("git+https://github.com/SuphalBhattarai/nepali-fonts")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "nepali-fonts"
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 nepali-fonts/fonts/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+}
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}