summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Valiska2018-03-30 19:57:44 +0200
committerJan Valiska2018-03-30 19:57:44 +0200
commitdac9a8ee896fd62942c7df879f7d09d671f8f24e (patch)
tree642c0d6a5d525ba06daaa9feefa0ac44ddfeefe7
downloadaur-dac9a8ee896fd62942c7df879f7d09d671f8f24e.tar.gz
Replace outdated package 'ttf-nerd-fonts-knack-complete-git'
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8b642717808
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ttf-nerd-fonts-hack-complete-git
+ pkgdesc = A typeface designed for source code. Patched with Nerd Fonts iconics.
+ pkgver = 20180330
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ license = MIT
+ depends = fontconfig
+ replaces = ttf-nerd-fonts-knack-complete-git
+ source = Hack-Regular-Nerd-Font-Complete.ttf::https://github.com/ryanoasis/nerd-fonts/raw/master/patched-fonts/Hack/Regular/complete/Hack%20Regular%20Nerd%20Font%20Complete.ttf
+ source = Hack-Regular-Nerd-Font-Complete-Mono.ttf::https://github.com/ryanoasis/nerd-fonts/raw/master/patched-fonts/Hack/Regular/complete/Hack%20Regular%20Nerd%20Font%20Complete%20Mono.ttf
+ source = Hack-Italic-Nerd-Font-Complete.ttf::https://github.com/ryanoasis/nerd-fonts/raw/master/patched-fonts/Hack/Italic/complete/Hack%20Italic%20Nerd%20Font%20Complete.ttf
+ source = Hack-Italic-Nerd-Font-Complete-Mono.ttf::https://github.com/ryanoasis/nerd-fonts/raw/master/patched-fonts/Hack/Italic/complete/Hack%20Italic%20Nerd%20Font%20Complete%20Mono.ttf
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ttf-nerd-fonts-hack-complete-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..609cd6a5c9b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: JanV3 <jan.valiska@gmail.com>
+pkgname=ttf-nerd-fonts-hack-complete-git
+pkgver=20180330
+pkgrel=1
+pkgdesc="A typeface designed for source code. Patched with Nerd Fonts iconics."
+arch=(any)
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+replaces=('ttf-nerd-fonts-knack-complete-git')
+raw_url="$url/raw/master/patched-fonts/Hack"
+
+# bold and bolditalic versions are temporarily disabled, because of empty ttf files on upstream
+source=(
+"Hack-Regular-Nerd-Font-Complete.ttf::$raw_url/Regular/complete/Hack%20Regular%20Nerd%20Font%20Complete.ttf"
+"Hack-Regular-Nerd-Font-Complete-Mono.ttf::$raw_url/Regular/complete/Hack%20Regular%20Nerd%20Font%20Complete%20Mono.ttf"
+#"Hack-Bold-Nerd-Font-Complete.ttf::$raw_url/Bold/complete/Hack%20Bold%20Nerd%20Font%20Complete.ttf"
+#"Hack-Bold-Nerd-Font-Complete-Mono.ttf::$raw_url/Bold/complete/Hack%20Bold%20Nerd%20Font%20Complete%20Mono.ttf"
+"Hack-Italic-Nerd-Font-Complete.ttf::$raw_url/Italic/complete/Hack%20Italic%20Nerd%20Font%20Complete.ttf"
+"Hack-Italic-Nerd-Font-Complete-Mono.ttf::$raw_url/Italic/complete/Hack%20Italic%20Nerd%20Font%20Complete%20Mono.ttf"
+#"Hack-BoldItalic-Nerd-Font-Complete.ttf::$raw_url/BoldItalic/complete/Hack%20Bold%20Italic%20Nerd%20Font%20Complete.ttf"
+#"Hack-BoldItalic-Nerd-Font-Complete-Mono.ttf::$raw_url/BoldItalic/complete/Hack%20Bold%20Italic%20Nerd%20Font%20Complete%20Mono.ttf"
+)
+#md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+package() {
+ install -dm0755 ${pkgdir}/usr/share/fonts/TTF
+ install -Dm0644 ${srcdir}/*.ttf ${pkgdir}/usr/share/fonts/TTF
+}