summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordangersalad2019-02-08 12:02:38 -0700
committerdangersalad2019-02-08 12:02:38 -0700
commit82d75b1e2eb87d54e620ccaafb931e20ba401f61 (patch)
treefd269173fdd3633e6515946ccfebc913408a134d
parent505819003f8445b1638696d3275d48c35554983e (diff)
downloadaur-82d75b1e2eb87d54e620ccaafb931e20ba401f61.tar.gz
update to nerd fonts 2.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14a247a411d5..77160e918b98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ttf-nerd-fonts-input
pkgdesc = Fonts for Code, from Font Bureau, patched with nerd-fonts
pkgver = 20170404
- pkgrel = 2
+ pkgrel = 3
url = http://input.fontbureau.com/
arch = any
license = custom:Font Software License Agreement
@@ -10,9 +10,9 @@ pkgbase = ttf-nerd-fonts-input
depends = xorg-fonts-encodings
depends = xorg-font-utils
source = Input_Fonts_20170404.zip::http://input.fontbureau.com/build/?fontSelection=whole&a=0&g=0&i=0&l=0&zero=0&asterisk=0&braces=0&preset=default&line-height=1.2&accept=I+do&email=
- source = https://github.com/ryanoasis/nerd-fonts/archive/v1.2.0.tar.gz
+ source = https://github.com/ryanoasis/nerd-fonts/archive/v2.0.0.tar.gz
sha256sums = 18c69fbe80ed468dbd8445074bd696eb316f0b9102db3bc59a4f89b0d6f6d31d
- sha256sums = c440409b76c86dc4a88be3d9ab5fb04092a176e6ff15ff2a61edc00861df0c2d
+ sha256sums = 0d5939042eff3b2d9b81ee2a871b3d2c046cbc6781f20ae87cdecfc1833e7bc8
pkgname = ttf-nerd-fonts-input
diff --git a/PKGBUILD b/PKGBUILD
index 767aaaa6f233..d8cde6bf7946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@
pkgname=ttf-nerd-fonts-input
pkgver=20170404
-pkgrel=2
+nerdfont_ver=2.0.0
+pkgrel=3
pkgdesc='Fonts for Code, from Font Bureau, patched with nerd-fonts'
arch=('any')
url='http://input.fontbureau.com/'
@@ -15,14 +16,16 @@ url_long="${url}build/?fontSelection=whole&a=0&g=0&i=0&l=0&zero=0&asterisk=0&bra
# go to the input website and try a download to get more info on how to customise this URL. Below are the setting I personally use, the default above matches the ttf-input package (all defaults on the website)
# url_long="${url}build/?fontSelection=whole&a=ss&g=ss&i=serifs_round&l=serifs_round&zero=0&asterisk=height&braces=0&preset=default&line-height=1.2&accept=I+do&email="
source=("Input_Fonts_${pkgver}.zip::${url_long}"
- "https://github.com/ryanoasis/nerd-fonts/archive/v1.2.0.tar.gz")
+ "https://github.com/ryanoasis/nerd-fonts/archive/v${nerdfont_ver}.tar.gz")
sha256sums=('18c69fbe80ed468dbd8445074bd696eb316f0b9102db3bc59a4f89b0d6f6d31d'
- 'c440409b76c86dc4a88be3d9ab5fb04092a176e6ff15ff2a61edc00861df0c2d')
+ '0d5939042eff3b2d9b81ee2a871b3d2c046cbc6781f20ae87cdecfc1833e7bc8')
+
+
package() {
mkdir -p ${pkgdir}/usr/share/fonts/TTF
find ${srcdir}/Input_Fonts -name '*.ttf' \
- -exec fontforge -script ${srcdir}/nerd-fonts-1.2.0/font-patcher \
+ -exec fontforge -script ${srcdir}/nerd-fonts-${nerdfont_ver}/font-patcher \
--no-progressbars --careful \
--complete --outputdir \
${pkgdir}/usr/share/fonts/TTF {} \;