summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpaulbdavis2018-02-15 18:17:41 -0700
committerpaulbdavis2018-02-15 18:17:41 -0700
commitb0a946dd1dbcdeaec9c3991f3328c6fce6954b4e (patch)
treecff80a42c05b7078a05bb66e91f2e55bc774a019
downloadaur-b0a946dd1dbcdeaec9c3991f3328c6fce6954b4e.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..803a8512f8bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-nerd-fonts-input
+ pkgdesc = Fonts for Code, from Font Bureau, patched with nerd-fonts
+ pkgver = 20170404
+ pkgrel = 1
+ url = http://input.fontbureau.com/
+ arch = any
+ license = custom:Font Software License Agreement
+ makedepends = fontforge
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = Input_Fonts_20170404.zip::http://input.fontbureau.com/build/?fontSelection=whole&a=0&g=0&i=0&l=0&zero=0&asterisk=0&braces=0&preset=default&line-height=1.2&accept=I+do&email=
+ source = https://github.com/ryanoasis/nerd-fonts/archive/v1.2.0.tar.gz
+ sha256sums = 712f9d2ca9c39a4de2fa044a78f7ef4e78d18b4f4ee4cddab9241a9199d7ea7f
+ sha256sums = c440409b76c86dc4a88be3d9ab5fb04092a176e6ff15ff2a61edc00861df0c2d
+
+pkgname = ttf-nerd-fonts-input
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b50dd4deb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Paul Davis ("dangersalad") <paul@dangersalad.com>
+# Old Maintainer: javier dot tia at gmail dot com
+# Older Maintainer: onestone at gmail dot com
+
+pkgname=ttf-nerd-fonts-input
+pkgver=20170404
+pkgrel=1
+pkgdesc='Fonts for Code, from Font Bureau, patched with nerd-fonts'
+arch=('any')
+url='http://input.fontbureau.com/'
+license=('custom:Font Software License Agreement')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('fontforge')
+url_long="${url}build/?fontSelection=whole&a=0&g=0&i=0&l=0&zero=0&asterisk=0&braces=0&preset=default&line-height=1.2&accept=I+do&email="
+# go to the input website and try a download to get more info on how to customise this URL. Below are the setting I personally use, the default above matches the ttf-input package (all defaults on the website)
+# url_long="${url}build/?fontSelection=whole&a=ss&g=ss&i=serifs_round&l=serifs_round&zero=0&asterisk=height&braces=0&preset=default&line-height=1.2&accept=I+do&email="
+source=("Input_Fonts_${pkgver}.zip::${url_long}"
+ "https://github.com/ryanoasis/nerd-fonts/archive/v1.2.0.tar.gz")
+sha256sums=('712f9d2ca9c39a4de2fa044a78f7ef4e78d18b4f4ee4cddab9241a9199d7ea7f'
+ 'c440409b76c86dc4a88be3d9ab5fb04092a176e6ff15ff2a61edc00861df0c2d')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/fonts/TTF
+ find ${srcdir}/Input_Fonts -name '*.ttf' \
+ -exec fontforge -script ${srcdir}/nerd-fonts-1.2.0/font-patcher \
+ --no-progressbars --careful \
+ --complete --outputdir \
+ ${pkgdir}/usr/share/fonts/TTF {} \;
+ chmod 644 ${pkgdir}/usr/share/fonts/TTF/*
+
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ cp ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}
+}