summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2020-05-18 16:49:14 +1200
committerGeorge Rawlinson2020-05-18 16:49:14 +1200
commite28acfa5e541033e8919f33f1f500c340bd2d58a (patch)
tree1b5729fe24eb70517ea2298251f26af6e804c60a
parentc5cbeb41a0f7d90c6d2eff1a3146bac44e37302d (diff)
downloadaur-e28acfa5e541033e8919f33f1f500c340bd2d58a.tar.gz
upgpkg: ttf-nishiki-teki 3.65s-1
Add pkgver function due to no versioning.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a92830c6deb..e60de695169e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ttf-nishiki-teki
pkgdesc = Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”
- pkgver = 3.65p
+ pkgver = 3.65s
pkgrel = 1
url = http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm
arch = any
license = custom
- source = ttf-nishiki-teki-3.65p.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip
+ source = ttf-nishiki-teki.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip
source = LICENSE
- sha512sums = 183b2286eeda0be92bd24bcc75d679e885a138af16726fb46c01d50167ed7be327ebdc041f9de09b62098e2cb9726dff74e6026e5edff09abae8a183d7024e9d
+ sha512sums = SKIP
sha512sums = f6138f41a7eade900bcda1a5be608cbb4a8205ce53c6d175d6ae13693ff34b8e2cdc42f9dd4ae49b7285a5f09c1fb4f077ad872361abb8303c1589acf5958436
pkgname = ttf-nishiki-teki
diff --git a/PKGBUILD b/PKGBUILD
index 661cb5ae76e6..34c225bd99a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
# Contributor: mock
+
pkgname=ttf-nishiki-teki
-pkgver=3.65p
+pkgver=3.65s
pkgrel=1
pkgdesc='Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”'
arch=('any')
url='http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm'
license=('custom')
-source=("$pkgname-$pkgver.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip"
+source=("$pkgname.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip"
"LICENSE")
-sha512sums=('183b2286eeda0be92bd24bcc75d679e885a138af16726fb46c01d50167ed7be327ebdc041f9de09b62098e2cb9726dff74e6026e5edff09abae8a183d7024e9d'
+sha512sums=('SKIP'
'f6138f41a7eade900bcda1a5be608cbb4a8205ce53c6d175d6ae13693ff34b8e2cdc42f9dd4ae49b7285a5f09c1fb4f077ad872361abb8303c1589acf5958436')
+pkgver() {
+ cd nishiki-teki_*
+ grep -Eo 'Version [[:digit:]]\.[[:digit:]]*[[:alpha:]]?' nishiki-teki.htm | head -n 1 | sed 's/Version //'
+}
+
package() {
- # this feels like a hacky workaround
cd nishiki-teki_*
# install font