summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-26 20:48:27 -0400
committerAlex Whitt2017-04-26 20:48:27 -0400
commitabb8b11c28f1ae95898d67c6c06f94130f8c09fa (patch)
tree5ba846e3d9e5a826358a02eb532cbabc874c3472
downloadaur-abb8b11c28f1ae95898d67c6c06f94130f8c09fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--ttf-octicons.install15
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36aa0d539d1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 00:42:55 UTC 2017
+pkgbase = ttf-octicons
+ pkgdesc = A scalable set of icons handcrafted with <3 by GitHub
+ pkgver = 4.3.0
+ pkgrel = 1
+ url = http://octicons.github.com/
+ install = ttf-octicons.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/primer/octicons/archive/v4.3.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = ttf-octicons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..601604a571b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=ttf-octicons
+pkgver=4.3.0
+pkgrel=1
+pkgdesc="A scalable set of icons handcrafted with <3 by GitHub"
+arch=('any')
+license=('MIT')
+url="http://octicons.github.com/"
+makedepends=('git')
+depends=('fontconfig' 'xorg-font-utils')
+source=("https://github.com/primer/octicons/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+install=$pkgname.install
+
+package() {
+ cd "${srcdir}/octicons-${pkgver}"
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 build/font/octicons.ttf $pkgdir/usr/share/fonts/TTF/
+}
diff --git a/ttf-octicons.install b/ttf-octicons.install
new file mode 100644
index 000000000000..db0951b4f496
--- /dev/null
+++ b/ttf-octicons.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo " ...done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file