summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-12 13:03:10 +0300
committerCaleb Maclennan2020-03-12 13:03:10 +0300
commitfd2fb706c85a2cec5497744bcc22a8cb2f9029f4 (patch)
treec27c6ea63b2d5f8424cb8ccbf7519040157a7cc1
parente26fa15ab47f595d7d5099a078e3ad67708455cb (diff)
downloadaur-fd2fb706c85a2cec5497744bcc22a8cb2f9029f4.tar.gz
Don't package OTF fonts in TTF package, drop obsolete dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbe693101c4f..41dbd55c142f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = ttf-ostrich-sans
- pkgdesc = A gorgeous modern sans-serif with a very long neck.
+ pkgdesc = A gorgeous modern sans-serif with a very long neck
pkgver = 20160215
- pkgrel = 2
+ pkgrel = 3
url = http://theleagueofmoveabletype.com/ostrich-sans
arch = any
groups = lmt-fonts
- license = custom:OFL
- depends = fontconfig
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
- source = ttf-ostrich-sans-20160215.zip::https://github.com/theleagueof/ostrich-sans/archive/master.zip
- md5sums = a30ecf58162f9c40040fcf74fcaef916
+ license = OFL
+ source = ttf-ostrich-sans-20160215.zip::https://github.com/theleagueof/ostrich-sans/archive/a949d40d0576d12ba26e2a45e19c91fd0228c964.zip
+ sha256sums = 962953c33c87ae9c5d6de678b3bc416504a5b2df92c12fd0389d1f5092a9127c
pkgname = ttf-ostrich-sans
diff --git a/PKGBUILD b/PKGBUILD
index 12cb059350ca..85c56c2d9885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=ostrich-sans
pkgname=ttf-$_fnt_name
pkgver=20160215
-pkgrel=2
-pkgdesc="A gorgeous modern sans-serif with a very long neck."
+# 20140418
+_sha=a949d40d0576d12ba26e2a45e19c91fd0228c964
+pkgrel=3
+pkgdesc="A gorgeous modern sans-serif with a very long neck"
arch=('any')
url="http://theleagueofmoveabletype.com/$_fnt_name"
-license=('custom:OFL')
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
-md5sums=('a30ecf58162f9c40040fcf74fcaef916')
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
+sha256sums=('962953c33c87ae9c5d6de678b3bc416504a5b2df92c12fd0389d1f5092a9127c')
package() {
- install -d "$pkgdir"/usr/share/fonts/OTF
- install -d "$pkgdir"/usr/share/fonts/TTF
- install -Dm644 "$srcdir/$_fnt_name"-master/*.otf "$pkgdir"/usr/share/fonts/OTF/
- install -Dm644 "$srcdir/$_fnt_name"-master/webfonts/*.ttf "$pkgdir"/usr/share/fonts/TTF/
-
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" webfonts/*.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}