summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreflexing2015-06-11 20:16:16 +0500
committerreflexing2015-06-11 20:16:16 +0500
commit5e5ce66080fe0e5ac8a491f1da98019121f3ca4d (patch)
treed0fa328a7b526964ced7189dcbc235dcb21bdb4f
downloadaur-5e5ce66080fe0e5ac8a491f1da98019121f3ca4d.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
-rw-r--r--ttf-paratype.install15
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00a86642b77e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ttf-paratype
+ pkgdesc = Font family by ParaType: sans, serif, mono, extended cyrillic and latin, OFL license
+ pkgver = 20140730
+ pkgrel = 1
+ url = http://www.paratype.com/public/
+ install = ttf-paratype.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-mkfontscale
+ depends = xorg-mkfontdir
+ provides = ttf-font
+ conflicts = ttf-pt-mono
+ conflicts = ttf-pt-sans
+ conflicts = ttf-pt-serif
+ source = PTSansOFL-20140730.zip::http://www.paratype.ru/uni/public/PTSansOFL.zip
+ source = PTSerifOFL-20140730.zip::http://www.paratype.ru/uni/public/PTSerifOFL.zip
+ source = PTMonoOFL-20140730.zip::http://www.paratype.ru/uni/public/PTMonoOFL.zip
+ md5sums = e5b99133d3b72cd35400b5aa810ad0ee
+ md5sums = 4dd07baa86fd30977cdfabd82bf2ad1d
+ md5sums = 1c6d5c30fca24130b2888b9427a75134
+
+pkgname = ttf-paratype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f10adcbb29ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: reflexing <reflexing@reflexing.ru>
+# Contributor: Alexander Zubkov <green@msu.ru>
+# Contributor: nsf
+#
+# Package is maintained on GitHub: https://github.com/reflexing/ttf-paratype
+
+pkgname=ttf-paratype
+pkgver=20140730
+pkgrel=1
+pkgdesc='Font family by ParaType: sans, serif, mono, extended cyrillic and latin, OFL license'
+arch=('any')
+url='http://www.paratype.com/public/'
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-mkfontscale' 'xorg-mkfontdir')
+conflicts=('ttf-pt-mono' 'ttf-pt-sans' 'ttf-pt-serif')
+provides=('ttf-font')
+install="$pkgname.install"
+source=(PTSansOFL-"$pkgver".zip::http://www.paratype.ru/uni/public/PTSansOFL.zip
+ PTSerifOFL-"$pkgver".zip::http://www.paratype.ru/uni/public/PTSerifOFL.zip
+ PTMonoOFL-"$pkgver".zip::http://www.paratype.ru/uni/public/PTMonoOFL.zip)
+
+package() {
+ # Prepare destination directory
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+
+ # Install fonts
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+
+ # Install license
+ install -Dm644 PTSSM_OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+md5sums=('e5b99133d3b72cd35400b5aa810ad0ee'
+ '4dd07baa86fd30977cdfabd82bf2ad1d'
+ '1c6d5c30fca24130b2888b9427a75134')
diff --git a/ttf-paratype.install b/ttf-paratype.install
new file mode 100644
index 000000000000..f5837f7f6e30
--- /dev/null
+++ b/ttf-paratype.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}