summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoya_daizu2024-03-18 14:53:50 +0900
committersoya_daizu2024-03-18 14:53:50 +0900
commit0f3dbeb3fa341431ed5ae4a94b5358186c804496 (patch)
tree70a1ccdd2513f70cb9a5b9b286325543e55bc13e
downloadaur-0f3dbeb3fa341431ed5ae4a94b5358186c804496.tar.gz
initial commit
-rwxr-xr-x.SRCINFO23
-rwxr-xr-xPKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..0a88d2adbd42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ttf-pending-mono
+ pkgdesc = A composite font of BIZ UD Gothic and Commit Mono
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/yuru7/pending-mono
+ arch = any
+ license = custom:SIL
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMono_v0.0.2.zip
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMonoNF_v0.0.2.zip
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMonoJPDOC_v0.0.2.zip
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMonoHW_v0.0.2.zip
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMonoHWNF_v0.0.2.zip
+ source = https://github.com/yuru7/pending-mono/releases/download/v0.0.2/PendingMonoHWJPDOC_v0.0.2.zip
+ source = https://raw.githubusercontent.com/yuru7/pending-mono/v0.0.2/LICENSE
+ sha256sums = 76388ee21bb11cf09b43fac154826e0da0499be6ffc49633e3f85b53f0947e3d
+ sha256sums = fefafcaa1af11c1841f8aa943205a7303b1a091f20ded17467cc414a9e863106
+ sha256sums = 9aadcdd6c95a737330842b23b0adba3eb6ad7208c377ee4823592f83c90c4da1
+ sha256sums = c03d8b16af20718fd0ce94b8658912f4f706e8ea8558b0564f6a90888e00460c
+ sha256sums = 67a2f9142999e19d30e8aeaac19ae15caf9d348fa726d17e80bb753f64ea50e4
+ sha256sums = fdf487f62573c5d37b28f50500d1bb94e2275209c4a23ada28ae724169411167
+ sha256sums = 9d23767271951afeaddbe5de4dec5d1cb60456c06f45e4d04fbb9ab517d79e30
+
+pkgname = ttf-pending-mono
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e2a781312e15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sosuke Inaba <mail[at]daizu[dot]dev>
+
+pkgname=ttf-pending-mono
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A composite font of BIZ UD Gothic and Commit Mono"
+arch=(any)
+url="https://github.com/yuru7/pending-mono"
+license=(custom:SIL)
+source=("$url/releases/download/v$pkgver/PendingMono_v$pkgver.zip"
+ "$url/releases/download/v$pkgver/PendingMonoNF_v$pkgver.zip"
+ "$url/releases/download/v$pkgver/PendingMonoJPDOC_v$pkgver.zip"
+ "$url/releases/download/v$pkgver/PendingMonoHW_v$pkgver.zip"
+ "$url/releases/download/v$pkgver/PendingMonoHWNF_v$pkgver.zip"
+ "$url/releases/download/v$pkgver/PendingMonoHWJPDOC_v$pkgver.zip"
+ "https://raw.githubusercontent.com/yuru7/pending-mono/v$pkgver/LICENSE")
+sha256sums=('76388ee21bb11cf09b43fac154826e0da0499be6ffc49633e3f85b53f0947e3d'
+ 'fefafcaa1af11c1841f8aa943205a7303b1a091f20ded17467cc414a9e863106'
+ '9aadcdd6c95a737330842b23b0adba3eb6ad7208c377ee4823592f83c90c4da1'
+ 'c03d8b16af20718fd0ce94b8658912f4f706e8ea8558b0564f6a90888e00460c'
+ '67a2f9142999e19d30e8aeaac19ae15caf9d348fa726d17e80bb753f64ea50e4'
+ 'fdf487f62573c5d37b28f50500d1bb94e2275209c4a23ada28ae724169411167'
+ '9d23767271951afeaddbe5de4dec5d1cb60456c06f45e4d04fbb9ab517d79e30')
+
+package() {
+ install -d $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMono_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMonoNF_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMonoJPDOC_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMonoHW_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMonoHWNF_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -m644 PendingMonoHWJPDOC_v$pkgver/*.ttf $pkgdir/usr/share/fonts/TTF
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
+}