summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2021-10-23 23:22:29 +0900
committerShohei Maruyama2021-10-23 23:27:33 +0900
commit1f1937a5139b93a9a4871494e53d3f804b8cefac (patch)
treeb6b46e1cd0411af4d0862d919f7597ff53f9f6d7
downloadaur-1f1937a5139b93a9a4871494e53d3f804b8cefac.tar.gz
Initial commit
Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05d93d951257
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-plemoljp
+ pkgdesc = Plex Mono Language JP
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/yuru7/PlemolJP
+ arch = any
+ license = custom:OFL
+ makedepends = fontforge
+ makedepends = python-fonttools
+ makedepends = ttfautohint
+ provides = ttf-font
+ source = git+https://github.com/yuru7/PlemolJP.git#tag=1.0.0
+ sha256sums = SKIP
+
+pkgname = ttf-plemoljp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5492a577072f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Shohei Maruyama <cheat.sc.linux@outlook.com>
+
+pkgname=ttf-plemoljp
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Plex Mono Language JP'
+arch=('any')
+url='https://github.com/yuru7/PlemolJP'
+license=('custom:OFL')
+provides=('ttf-font')
+makedepends=('fontforge' 'python-fonttools' 'ttfautohint')
+source=("git+https://github.com/yuru7/PlemolJP.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd PlemolJP
+ ./make.sh
+}
+
+package() {
+ cd PlemolJP
+ find build -type f -name '*.ttf' -exec install -Dm644 {} -t "${pkgdir}/usr/share/fonts/PlemolJP" \;
+ install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}