summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStezkoy2020-02-14 15:10:55 +0500
committerJonas Witschel2020-03-08 23:07:02 +0100
commit2553f28528d95428c5723d75c18a7236fa1699f6 (patch)
treea7c34ce5fa710e7d1b86d18e30413b918446de45
downloadaur-ttf-product-sans.tar.gz
ignore
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
-rw-r--r--ttf-product-sans.install11
4 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d22090324c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-product-sans
+ pkgdesc = Product Sans is a geometric sans-serif typeface created by Google for branding purposes.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.google.com/
+ install = ttf-product-sans.install
+ arch = any
+ license = Proprietary
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = local://product.ttf
+ sha256sums = d23139478aa3b37805e6790e32ec724ff5622cffb1633832b062538a3b0055a5
+
+pkgname = ttf-product-sans
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4f752c559aa4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..989b1be36d7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Stezkoy <seracam@yandex.ru>
+pkgname=ttf-product-sans
+pkgver=1.0
+pkgrel=1
+pkgdesc="Product Sans is a geometric sans-serif typeface created by Google for branding purposes."
+arch=('any')
+license=('Proprietary')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf-product-sans.install
+url="https://www.google.com/"
+source=('local://product.ttf')
+
+package() {
+ install -Dm0644 product.ttf $pkgdir/usr/share/fonts/TTF/product.ttf
+}
+
+sha256sums=('d23139478aa3b37805e6790e32ec724ff5622cffb1633832b062538a3b0055a5')
diff --git a/ttf-product-sans.install b/ttf-product-sans.install
new file mode 100644
index 000000000000..ac41c6502473
--- /dev/null
+++ b/ttf-product-sans.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n "Updating font cache..."
+ fc-cache -fs > /dev/null
+ mkfontdir /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/TTF
+ echo "Done"
+}
+
+post_upgrade() {
+ post_install
+}