aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Albertz2015-10-16 11:42:49 +0200
committerFlorian Albertz2015-10-16 11:42:49 +0200
commitda41f3bb51810d53d498ada2cbf36b393ae1df20 (patch)
tree65e5a998b42636d3abe16af4d3e2c99fb424007c
downloadaur-da41f3bb51810d53d498ada2cbf36b393ae1df20.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--LICENSE12
-rw-r--r--PKGBUILD17
-rw-r--r--ttf-profont-iix.install15
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c2c8d35a867
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Fri Oct 16 09:41:59 UTC 2015
+pkgbase = ttf-profont-iix
+ pkgdesc = Profont IIx Variant as a Truetype Font
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://tobiasjung.name/profont/
+ install = ttf-profont-iix.install
+ arch = any
+ license = MIT
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://tobiasjung.name/downloadfile.php?file=profontiix.zip
+ sha256sums = 9d118ffd8f80e8b9952d2ae24d13d89149ebb5e9459b9e2a2cc33e1a460c1bfa
+
+pkgname = ttf-profont-iix
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..09d0d7ab05c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.pkg.tar.xz
+/*.zip
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6de90bf5f1e0
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,12 @@
+Copyright (c) 2015, Florian Albertz
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..532af1b779e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Florian Albertz <flo.albertz@gmail.com>
+pkgname="ttf-profont-iix"
+pkgver="1.0.0"
+pkgrel=1
+pkgdesc='Profont IIx Variant as a Truetype Font'
+arch=('any')
+url='http://tobiasjung.name/profont/'
+license=('MIT')
+depends=(fontconfig xorg-font-utils)
+source=('http://tobiasjung.name/downloadfile.php?file=profontiix.zip')
+sha256sums=('9d118ffd8f80e8b9952d2ae24d13d89149ebb5e9459b9e2a2cc33e1a460c1bfa')
+install=$pkgname.install
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "$srcdir/profontiix/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
diff --git a/ttf-profont-iix.install b/ttf-profont-iix.install
new file mode 100644
index 000000000000..d11a6d7f088b
--- /dev/null
+++ b/ttf-profont-iix.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}