summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-03-10 18:17:47 +0100
committerfelics2018-03-10 18:17:47 +0100
commit99d464c99d924687bcc358b22035e49524ad5cc0 (patch)
treec319f960b2a540d08e64e97a53d799823dc00815
downloadaur-99d464c99d924687bcc358b22035e49524ad5cc0.tar.gz
Initial commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
-rw-r--r--license-dummy.txt5
-rw-r--r--revelation.install14
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57d3dd5b54b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ttf-revelation
+ pkgdesc = The hand-written font for Myst IV Revelation journals.
+ pkgver = latest
+ pkgrel = 1
+ url = http://www.rshayter.com/downloads/
+ install = revelation.install
+ arch = any
+ license = custom
+ makedepends = fontconfig
+ makedepends = xorg-mkfontscale
+ makedepends = xorg-mkfontdir
+ makedepends = xorg-xset
+ provides = ttf-dniscript=latest
+ source = revelation.ttf::http://www.rshayter.com/files/Revelation.ttf
+ source = license-dummy.txt
+ source = revelation.install
+ sha256sums = 0e0fde843486d814f3831f9f482884543d315e90e05cb539e8a6bce678b88c74
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ttf-revelation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91f419a4b21e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: dreieck
+
+_pkgname=ttf-revelation
+pkgname="${_pkgname}"
+pkgver=latest
+pkgrel=1
+pkgdesc="The hand-written font for Myst IV Revelation journals."
+arch=('any')
+url="http://www.rshayter.com/downloads/"
+license=('custom')
+
+depends=(
+)
+
+makedepends=(
+ "fontconfig"
+ "xorg-mkfontscale"
+ "xorg-mkfontdir"
+ "xorg-xset"
+)
+
+provides=("ttf-dniscript=${pkgver}")
+
+install='revelation.install'
+
+source=(
+ "revelation.ttf::http://www.rshayter.com/files/Revelation.ttf"
+ "license-dummy.txt"
+ "${install}"
+)
+
+sha256sums=(
+ "0e0fde843486d814f3831f9f482884543d315e90e05cb539e8a6bce678b88c74"
+ "SKIP"
+ "SKIP"
+)
+
+prepare() {
+ cd "${srcdir}"
+ echo "${url}" > "${srcdir}/website.url"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -D -v -m644 'revelation.ttf' "${pkgdir}/usr/share/fonts/revelation
+ /revelation.ttf"
+
+ install -D -v -m644 license-dummy.txt "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -v -m644 website.url "${pkgdir}/usr/share/doc/${_pkgname}/website.url"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..6a9e241d6449
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,5 @@
+We do not know the license.
+
+Assume all rights to the creator(s) of the game "Myst IV revelation".
+
+Upstream URL: http://www.rshayter.com/downloads/
diff --git a/revelation.install b/revelation.install
new file mode 100644
index 000000000000..ee32300d6de1
--- /dev/null
+++ b/revelation.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating font cache ... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/revelation
+ mkfontdir /usr/share/fonts/revelation
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+
+post_remove() {
+ post_install "$@"
+}