summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-04-04 09:29:51 -0400
committerErik Dubois2017-04-04 09:29:51 -0400
commitcf6feb16b41fb0ea929b30961f7fa26467382300 (patch)
tree004670a2bd695987a31a333ffd34ad88d0a5616d
downloadaur-cf6feb16b41fb0ea929b30961f7fa26467382300.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--45-roboto.conf26
-rw-r--r--90-tt-roboto.conf71
-rw-r--r--PKGBUILD45
4 files changed, 169 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b14647f5d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Tue Apr 4 13:29:43 UTC 2017
+pkgbase = ttf-roboto-ibx
+ pkgdesc = Modern sans-serif font family designed by Christian Robertson and introduced with Android Ice Cream Sandwich operating system. Basic, condensed and slab variants included.
+ pkgver = 2.136
+ pkgrel = 1
+ url = http://code.google.com/android/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = Apache
+ depends = fontconfig
+ conflicts = ttf-roboto
+ conflicts = ttf-roboto-fontconfig
+ conflicts = ttf-roboto-slab
+ source = https://github.com/google/roboto/releases/download/v2.136/roboto-hinted.zip
+ source = Roboto_Condensed.zip::https://fonts.google.com/download?family=Roboto%20Condensed
+ source = Roboto_Slab.zip::https://fonts.google.com/download?family=Roboto%20Slab
+ source = 45-roboto.conf
+ source = 90-tt-roboto.conf
+ sha1sums = 6ac3eb489359fae05a80411bdf12f22e064b1011
+ sha1sums = 73dcb814feea819ac13a2a1942b83ec6fecb73e4
+ sha1sums = a63d1390fcdce3eba61679c0f16786ac64d4c0f3
+ sha1sums = 8ff0fd3af47b4234cdb40746a29aa613fc8dc502
+ sha1sums = 05cffa42f1ac56bf5595afe2ab67e656555273fb
+
+pkgname = ttf-roboto-ibx
+
diff --git a/45-roboto.conf b/45-roboto.conf
new file mode 100644
index 000000000000..87748b360c33
--- /dev/null
+++ b/45-roboto.conf
@@ -0,0 +1,26 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Roboto</family>
+ <default>
+ <family>sans-serif</family>
+ </default>
+ </alias>
+
+ <alias>
+ <family>Roboto Condensed</family>
+ <default>
+ <family>sans-serif</family>
+ </default>
+ </alias>
+
+ <alias>
+ <family>Roboto Slab</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-roboto.conf b/90-tt-roboto.conf
new file mode 100644
index 000000000000..24251137fe5a
--- /dev/null
+++ b/90-tt-roboto.conf
@@ -0,0 +1,71 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <!-- Roboto -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Roboto</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ </match>
+
+ <!-- Roboto Condensed -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Roboto Condensed</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <!-- Roboto Slab -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Roboto Slab</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04512f97937d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Mainainer: bohoomil <@zoho.com>
+
+pkgname=ttf-roboto-ibx
+pkgver=2.136
+pkgrel=1
+pkgdesc="Modern sans-serif font family designed by Christian Robertson and introduced with Android Ice Cream Sandwich operating system. Basic, condensed and slab variants included."
+arch=('any')
+license=('Apache')
+url="http://code.google.com/android/"
+depends=('fontconfig')
+groups=('infinality-bundle-fonts-extra')
+conflicts=('ttf-roboto' 'ttf-roboto-fontconfig' 'ttf-roboto-slab')
+# http://www.google.com/fonts
+# all scripts
+source=(https://github.com/google/roboto/releases/download/v$pkgver/roboto-hinted.zip
+ Roboto_Condensed.zip::https://fonts.google.com/download?family=Roboto%20Condensed
+ Roboto_Slab.zip::https://fonts.google.com/download?family=Roboto%20Slab
+ 45-roboto.conf
+ 90-tt-roboto.conf)
+validgpgkeys=('A9244FB5E93F11F0E975337FAE6866C7962DDE58')
+sha1sums=('6ac3eb489359fae05a80411bdf12f22e064b1011'
+ '73dcb814feea819ac13a2a1942b83ec6fecb73e4'
+ 'a63d1390fcdce3eba61679c0f16786ac64d4c0f3'
+ '8ff0fd3af47b4234cdb40746a29aa613fc8dc502'
+ '05cffa42f1ac56bf5595afe2ab67e656555273fb')
+
+package(){
+ install -D -m644 "LICENSE.txt" \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -d -m755 "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 roboto-hinted/*.ttf \
+ "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -D -m644 45-roboto.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-roboto.conf
+ install -D -m644 90-tt-roboto.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-roboto.conf
+
+ install -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-roboto.conf .
+ ln -s ../conf.avail/90-tt-roboto.conf .
+}