summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-04-04 09:06:33 -0400
committerErik Dubois2017-04-04 09:06:33 -0400
commita8729abfd65ff3eec0b8b065d71f51d742fbbf7c (patch)
treedc0299b9aaf8f3671dfe617d740f700bd8cd24f3
downloadaur-a8729abfd65ff3eec0b8b065d71f51d742fbbf7c.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--45-roboto-mono.conf12
-rw-r--r--90-tt-roboto-mono.conf26
-rw-r--r--PKGBUILD42
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..137f2be225e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Apr 4 13:06:19 UTC 2017
+pkgbase = ttf-roboto-mono-ibx
+ pkgdesc = Monospace variant of the Google Roboto font family.
+ pkgver = 2.0
+ pkgrel = 4
+ url = http://code.google.com/android/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = Apache
+ depends = fontconfig
+ conflicts = ttf-roboto-mono
+ source = Roboto_Mono.zip::https://fonts.google.com/download?family=Roboto%20Mono
+ source = 45-roboto-mono.conf
+ source = 90-tt-roboto-mono.conf
+ sha1sums = cff45f40b590094eb0dcbc6359d1daabaee5069c
+ sha1sums = 022fa31ea75d8978aa8c5cf6c7efc5af2431b943
+ sha1sums = 272491d73a59e9d0ac8200c16e3b31657db58cf8
+
+pkgname = ttf-roboto-mono-ibx
+
diff --git a/45-roboto-mono.conf b/45-roboto-mono.conf
new file mode 100644
index 000000000000..99e49a41a0d4
--- /dev/null
+++ b/45-roboto-mono.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Roboto Mono</family>
+ <default>
+ <family>monospace</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-roboto-mono.conf b/90-tt-roboto-mono.conf
new file mode 100644
index 000000000000..9ea1f0264d65
--- /dev/null
+++ b/90-tt-roboto-mono.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Roboto Mono</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f43a1c0426a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Mainainer: bohoomil <@zoho.com>
+
+pkgname=ttf-roboto-mono-ibx
+pkgver=2.0
+pkgrel=4
+pkgdesc="Monospace variant of the Google Roboto font family."
+arch=('any')
+license=('Apache')
+url="http://code.google.com/android/"
+depends=('fontconfig')
+groups=('infinality-bundle-fonts-extra')
+conflicts=('ttf-roboto-mono')
+# http://www.google.com/fonts
+# all scripts
+source=(Roboto_Mono.zip::https://fonts.google.com/download?family=Roboto%20Mono
+ 45-roboto-mono.conf
+ 90-tt-roboto-mono.conf)
+validgpgkeys=('A9244FB5E93F11F0E975337FAE6866C7962DDE58')
+sha1sums=('cff45f40b590094eb0dcbc6359d1daabaee5069c'
+ '022fa31ea75d8978aa8c5cf6c7efc5af2431b943'
+ '272491d73a59e9d0ac8200c16e3b31657db58cf8')
+
+package(){
+ cd $srcdir/
+
+ install -D -m644 "LICENSE.txt" \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -d -m755 "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ cd "${srcdir}"
+ install -D -m644 45-roboto-mono.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-roboto-mono.conf
+ install -D -m644 90-tt-roboto-mono.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-roboto-mono.conf
+
+ install -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-roboto-mono.conf .
+ ln -s ../conf.avail/90-tt-roboto-mono.conf .
+}