summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:22:06 -0700
committerGavin Lloyd2015-06-09 17:22:06 -0700
commit7eb7f26c6fb15427d3a443e33602dfa63706c4ac (patch)
tree630f8b26524333cfea015a7b4d73f8625aeef518
downloadaur-7eb7f26c6fb15427d3a443e33602dfa63706c4ac.tar.gz
Init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--ttf-roboto-slab.install18
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcfb86d42b1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-roboto-slab
+ pkgdesc = Serif Roboto font from Google Keep
+ pkgver = 1.100262
+ pkgrel = 3
+ url = https://www.google.com/fonts/specimen/Roboto+Slab
+ install = ttf-roboto-slab.install
+ arch = any
+ license = APACHE
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://gavinhungry.io/pub/Roboto_Slab.zip
+ md5sums = 1222eadc0fece6cded684fcff6ec230b
+
+pkgname = ttf-roboto-slab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..369fdff45329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=ttf-roboto-slab
+pkgver=1.100262
+pkgrel=3
+pkgdesc='Serif Roboto font from Google Keep'
+arch=('any')
+license=('APACHE')
+url='https://www.google.com/fonts/specimen/Roboto+Slab'
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+source=('https://gavinhungry.io/pub/Roboto_Slab.zip')
+md5sums=('1222eadc0fece6cded684fcff6ec230b')
+install=$pkgname.install
+
+package() {
+ install -d $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 *.ttf $pkgdir/usr/share/fonts/TTF/
+}
+
diff --git a/ttf-roboto-slab.install b/ttf-roboto-slab.install
new file mode 100644
index 000000000000..c574655354ca
--- /dev/null
+++ b/ttf-roboto-slab.install
@@ -0,0 +1,18 @@
+post_install() {
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*