summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorboronology2015-06-08 19:30:44 +0900
committerboronology2015-06-08 19:30:44 +0900
commit6f88f7a42d561fbce302323fa59f89da2a53a710 (patch)
treed359657b026982aca43649caa1a9a24973aaac65
downloadaur-6f88f7a42d561fbce302323fa59f89da2a53a710.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--ttf-rounded-mplus.install16
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bea2aad5d8d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ttf-rounded-mplus
+ pkgdesc = Japanese rounded gothic fonts based on M+ FONTS
+ pkgver = 20150110
+ pkgrel = 3
+ url = http://jikasei.me/font/rounded-mplus/
+ install = ttf-rounded-mplus.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://sourceforge.jp/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F7%2F7708%2Frounded-mplus-20150110.7z
+ source = http://sourceforge.jp/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F7%2F7709%2Frounded-x-mplus-20150110.7z
+ source = http://sourceforge.jp/frs/chamber_redir.php?m=osdn&f=%2Fusers%2F7%2F7707%2Frounded-l-mplus-20150110.7z
+ md5sums = 4fa76a841c83bc296ea19a6f6f56b553
+ md5sums = 4c0e6167d5d35bb685b86acb2653deb7
+ md5sums = 716d686eee8b402805db51c461da2c84
+
+pkgname = ttf-rounded-mplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e48e611a71f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer : boronology <boronology at gmail dot com>
+pkgname=ttf-rounded-mplus
+pkgver=20150110
+pkgrel=3
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc="Japanese rounded gothic fonts based on M+ FONTS"
+arch=('any')
+license=('custom')
+url="http://jikasei.me/font/rounded-mplus/"
+source=("http://sourceforge.jp/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F7%2F7708%2Frounded-mplus-20150110.7z"
+ "http://sourceforge.jp/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F7%2F7709%2Frounded-x-mplus-20150110.7z"
+ "http://sourceforge.jp/frs/chamber_redir.php?m=osdn&f=%2Fusers%2F7%2F7707%2Frounded-l-mplus-20150110.7z"
+ )
+
+install=$pkgname.install
+
+package() {
+ cd "$srcdir"
+
+ # install fonts
+ for TTF in `ls | grep ttf`
+ do
+ install -Dm644 $TTF "$pkgdir/usr/share/fonts/TTF/$TTF"
+ done
+
+ # install License
+ for LICENSE in `ls mplus-TESTFLIGHT-059 | grep LICENSE`
+ do
+ install -Dm644 mplus-TESTFLIGHT-059/$LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/$LICENSE"
+ done
+}
+
+md5sums=('4fa76a841c83bc296ea19a6f6f56b553'
+ '4c0e6167d5d35bb685b86acb2653deb7'
+ '716d686eee8b402805db51c461da2c84')
diff --git a/ttf-rounded-mplus.install b/ttf-rounded-mplus.install
new file mode 100644
index 000000000000..eec0b9d326f8
--- /dev/null
+++ b/ttf-rounded-mplus.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Upgradeing font cache..."
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done!"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+