summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Rice2015-06-24 04:25:53 +1000
committerTimothy Rice2015-06-24 04:25:53 +1000
commit556cc355b8a5cad76f74495f3534b07f2f5c7c0b (patch)
treea77c1e1fa06b93dd949c81fa9b5d137549601f56
downloadaur-556cc355b8a5cad76f74495f3534b07f2f5c7c0b.tar.gz
Initial import.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
-rw-r--r--ttf.install15
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ed134776a81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-sans-bullshit-sans
+ pkgdesc = The font that replaces every buzzword by a Comic Sans-styled censorship bar.
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.sansbullshitsans.com/
+ install = ttf.install
+ arch = any
+ license = APACHE
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://pixelambacht.nl/downloads/SansBullshitSans.ttf
+ md5sums = 1b1644f29e2f9981d1d67b561bb47348
+
+pkgname = ttf-sans-bullshit-sans
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..237326a9449d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+SansBullshitSans.ttf
+ttf-sans-bullshit-sans-*.tar.*
+*.swp
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af772fa89b89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: "devzero" (Tim Rice) <t dot rice at ms dot unimelb dot edu dot au>
+pkgname=ttf-sans-bullshit-sans
+_realname=SansBullshitSans
+pkgver=1.0
+pkgrel=2
+pkgdesc="The font that replaces every buzzword by a Comic Sans-styled censorship bar."
+arch=(any)
+url="http://www.sansbullshitsans.com/"
+license=('APACHE')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://pixelambacht.nl/downloads/${_realname}.ttf)
+
+build() { :
+}
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+md5sums=('1b1644f29e2f9981d1d67b561bb47348')
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}